Closed Thread
Results 1 to 2 of 2

Reload Thread: '93 Bronco setup

  1. #1
    Broncokid's Avatar
    Broncokid is offline Junior Member



    Join Date
    Oct 2010
    Location
    NC
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    '93 Bronco setup

    Hey what's up? I recently bought 2 Kicker 10" 10C104 subs and a Kicker zx700.5 amp to power my entire system. I have had pioneer 6.5" and 6X9" components, to replace the stock speakers, for about 2 years now. My question is this: should i replace my stock 95 amp alternator with a high output alternator?

    Also, i'm wondering if the amp can power the entire system adequately and if i even SHOULD power the component speakers. The 6.5's are rated 35w and the 6X9's are rated 40w. The Subs are rated 150w per sub. I also have a Kenwood HU but i'm not sure the specs on it. If it's relevant, let me know and i'll find out. also these ratings are all RMS, not peak so yeah..

    Also i haven't installed any of this stuff yet, as i'm waiting on my amp to arrive and i still have to build a box for the woofers.







  2. #2
    misfit138's Avatar
    misfit138 is offline a whole new type of aids



    Join Date
    Jun 2009
    Location
    Williamson, WV
    Posts
    12,048
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: '93 Bronco setup

    You should've come here first. We could've lead you in a much better direction...



    I shot out muh mom's vag with bossing papers in hand.

Closed Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum