Closed Thread
Results 1 to 11 of 11

Reload Thread: Help Fast Please Think I Burnt My Sub With New Amp

  1. #1
    BiaBia's Avatar
    BiaBia is online now Senior VIP Member



    Join Date
    Jun 2003
    Location
    Hampton, VA
    Posts
    1,379
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Help Fast Please Think I Burnt My Sub With New Amp

    I just got my new amp about an hour ago, the Hifonics Brutus bx1500d amp. I was convinced to buy it ever since I went to a friends house and tried out his hifonics on my sub.

    Anyways, I unhook my old amp and I get a spark from the ground, so i'm like.. ****. I had my sub unhooked anyways, so no risk there, ****** amp. I hook the new one in, same thing happens. So I decide to try anyways like a *******, and I get no bass. Remote wire checked, wires checked and recut, ground checked, battery checked, everything was alright. So I asked a few friends on AIM and I decide to put old amp back on, and my sub works!

    I hook the new amp back up, my sub DOESNT WORK! The lights are on, everything alright, cept NO BASS. When I turned the bass knob up, the sub flexed like it would if it was hitting. Can someone help me out?



    -Alex
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    AIM - Biabia322
    E-mail - ulyessz@hotmail.com

    1993 300zx Slicktop - Undergoing TT transplant
    HU - Pioneer Premier 740mp
    Front Stage - Rainbow SLC 265
    Front Stage Amp - US Amps 800.2
    Subwoofers - (2) 10'' Sundown SD-1's
    Subwoofers Amp - Sundown 100.4

    "When my GF's 9-year-old niece told me that she would "pop" me in the mouth if I told her to be quiet again, I retorted, "Pop me in the mouth and I'll pop your cherry." -Jmac





  2. #2
    Aurorav8's Avatar
    Aurorav8 is offline CarAudio.com Elite



    Join Date
    Apr 2003
    Location
    Fort Wayne
    Age
    35
    Posts
    1,610
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Quote Originally Posted by BiaBia
    I just got my new amp about an hour ago, the Hifonics Brutus bx1500d amp. I was convinced to buy it ever since I went to a friends house and tried out his hifonics on my sub.

    Anyways, I unhook my old amp and I get a spark from the ground, so i'm like.. ****. I had my sub unhooked anyways, so no risk there, ****** amp. I hook the new one in, same thing happens. So I decide to try anyways like a *******, and I get no bass. Remote wire checked, wires checked and recut, ground checked, battery checked, everything was alright. So I asked a few friends on AIM and I decide to put old amp back on, and my sub works!

    I hook the new amp back up, my sub DOESNT WORK! The lights are on, everything alright, cept NO BASS. When I turned the bass knob up, the sub flexed like it would if it was hitting. Can someone help me out?
    Gains set?

    All wiring correct? RCA's and all?



    God is just an imaginary friend for grown ups.

  3. #3
    BiaBia's Avatar
    BiaBia is online now Senior VIP Member

    Threadstarter


    Join Date
    Jun 2003
    Location
    Hampton, VA
    Posts
    1,379
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    I've hooked this amp up before, and even then, I checked and rechecked. This **** is so simple to me.



    -Alex
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    AIM - Biabia322
    E-mail - ulyessz@hotmail.com

    1993 300zx Slicktop - Undergoing TT transplant
    HU - Pioneer Premier 740mp
    Front Stage - Rainbow SLC 265
    Front Stage Amp - US Amps 800.2
    Subwoofers - (2) 10'' Sundown SD-1's
    Subwoofers Amp - Sundown 100.4

    "When my GF's 9-year-old niece told me that she would "pop" me in the mouth if I told her to be quiet again, I retorted, "Pop me in the mouth and I'll pop your cherry." -Jmac


  4. #4
    Aurorav8's Avatar
    Aurorav8 is offline CarAudio.com Elite



    Join Date
    Apr 2003
    Location
    Fort Wayne
    Age
    35
    Posts
    1,610
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Quote Originally Posted by BiaBia
    I've hooked this amp up before, and even then, I checked and rechecked. This **** is so simple to me.
    Just making sure you didn't overlook the obvious. It's easy to do that.



    God is just an imaginary friend for grown ups.

  5. #5
    DBfan187's Avatar
    DBfan187 is offline Supa's mom was here!



    Join Date
    Jan 2003
    Location
    Poolside with Supa's mom.
    Posts
    46,452
    Post Thanks / Like
    Images
    12
    Mentioned
    1 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Open amp up. Smell anything? Look for burn marks, especially on the edges around the transistors/semi-conductors!




  6. #6
    BiaBia's Avatar
    BiaBia is online now Senior VIP Member

    Threadstarter


    Join Date
    Jun 2003
    Location
    Hampton, VA
    Posts
    1,379
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Opened it, no burns, no scratches, no disconnected pieces. Any other ideas?



    -Alex
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    AIM - Biabia322
    E-mail - ulyessz@hotmail.com

    1993 300zx Slicktop - Undergoing TT transplant
    HU - Pioneer Premier 740mp
    Front Stage - Rainbow SLC 265
    Front Stage Amp - US Amps 800.2
    Subwoofers - (2) 10'' Sundown SD-1's
    Subwoofers Amp - Sundown 100.4

    "When my GF's 9-year-old niece told me that she would "pop" me in the mouth if I told her to be quiet again, I retorted, "Pop me in the mouth and I'll pop your cherry." -Jmac


  7. #7
    Bavarian3's Avatar
    Bavarian3 is offline Ownz joo



    Join Date
    Mar 2003
    Location
    Nor*Cal
    Age
    27
    Posts
    5,170
    Post Thanks / Like
    Images
    9
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    check the speaker wire inputs on the amp. i remember similar people having this problem because the inputs are ++-- instead of +-+-



    Upcoming SQ competition ready install...
    -Eclipse cd8053
    -Image Dynamics Cd1Pro MH
    -Image Dynamics 6.5" mids with CX motors and poly cone in custom fiberglass kick panels
    -12" Stereo Integrity Magnum in large sealed fiberglass wheel well enclosure.
    -Viper d1200.1 (sub), Viper 400.2 (mids), David Navone Amp-100 (horns)



  8. #8
    BiaBia's Avatar
    BiaBia is online now Senior VIP Member

    Threadstarter


    Join Date
    Jun 2003
    Location
    Hampton, VA
    Posts
    1,379
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Did that too.. should I wire it to a different ohm.. its at 1 ohm now



    -Alex
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    AIM - Biabia322
    E-mail - ulyessz@hotmail.com

    1993 300zx Slicktop - Undergoing TT transplant
    HU - Pioneer Premier 740mp
    Front Stage - Rainbow SLC 265
    Front Stage Amp - US Amps 800.2
    Subwoofers - (2) 10'' Sundown SD-1's
    Subwoofers Amp - Sundown 100.4

    "When my GF's 9-year-old niece told me that she would "pop" me in the mouth if I told her to be quiet again, I retorted, "Pop me in the mouth and I'll pop your cherry." -Jmac


  9. #9
    Aurorav8's Avatar
    Aurorav8 is offline CarAudio.com Elite



    Join Date
    Apr 2003
    Location
    Fort Wayne
    Age
    35
    Posts
    1,610
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Quote Originally Posted by BiaBia
    Did that too.. should I wire it to a different ohm.. its at 1 ohm now
    Is it 1 ohm stable?



    God is just an imaginary friend for grown ups.

  10. #10
    buchel's Avatar
    buchel is offline Veteran n00b



    Join Date
    Feb 2002
    Location
    Ontario, Canada
    Age
    27
    Posts
    356
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Quote Originally Posted by Aurorav8
    Is it 1 ohm stable?
    Sure is...

    ~ Kyle ~



    Quote Originally Posted by Gauntlet
    Your father should have pulled out.

  11. #11
    smullen's Avatar
    smullen is offline CarAudio.com Elite



    Join Date
    Aug 2003
    Location
    St. Louis
    Age
    40
    Posts
    1,963
    Post Thanks / Like
    Images
    29
    Mentioned
    0 Post(s)

    Re: Help Fast Please Think I Burnt My Sub With New Amp

    Do you have a different speaker you could try??? Could even be a small mid, just keep the gains down... I keep a pair of crappy speakers on stand by for this exact reason...




Closed Thread

Similar Threads

  1. Wiring speakers to amp and headunit??
    By llknowlesll in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 12-30-2003, 10:23 AM
  2. Wire speakers to amp and headunit??
    By llknowlesll in forum Amplifiers
    Replies: 1
    Last Post: 12-30-2003, 04:20 AM
  3. Capacitor on a 300W amp?
    By Darwin in forum General Discussion
    Replies: 20
    Last Post: 12-29-2003, 04:24 PM
  4. need help choosing an amp fast for my CDT 61a
    By mdd99 in forum Amplifiers
    Replies: 3
    Last Post: 09-18-2003, 07:44 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum