Closed Thread
Results 1 to 6 of 6

Reload Thread: need help for buddy's s-10 system

  1. #1
    mrmagoo_83's Avatar
    mrmagoo_83 is offline Registered User



    Join Date
    Feb 2002
    Location
    Fort Worth, Tx
    Age
    34
    Posts
    102
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon32 need help for buddy's s-10 system

    Ok my buddy drives a '98 s-10. We had a Jensen amp pushing a punch 10. I know dont throw anything at me please. Anyway, the sub quit, probably from lack of power. He wants to spend $400 on a decent system, well actually below decent, he is spending $200 of the $400 on a receiver. So I was looking at carstereotime.com and saw they had an Alpine Amp for $99, that puts out 130Watts RMS. Which is a good price I guess. Is carstereotime a credable dealer? I need some advice on the sub though. The amp pushes 240Watts max, so I need a sub that can handle 130RMS and 240 max. I think we will stick with Alpine to match unless y'all have a better idea. THanks for the help.
    mrmagoo







  2. #2
    McCraperson's Avatar
    McCraperson is offline Member



    Join Date
    Dec 2001
    Location
    Calgary, Alberta
    Posts
    59
    Post Thanks / Like
    Mentioned
    0 Post(s)
    i say go with kenwood tornadoes, i have 2 12s and they sound pretty good in a sealed with 130 rms to them, the handle 160 rms, but my amp won't push that much...




  3. #3
    MikeofTulsa's Avatar
    MikeofTulsa is offline The one and Only!



    Join Date
    Feb 2002
    Location
    Tulsa, OK
    Posts
    20,885
    Post Thanks / Like
    Images
    8
    Mentioned
    37 Post(s)
    well as for the jensen amp....i have previously owned one of the 400W models...it put out 150W rms x 2 and it sounded pretty good....of course back then i was a "volume master" and had the gains set too high....but you cant blow a speaker because it didnt get enough power.....so if you could give us a little more information about the amp and how high the gains were set and all that we could probably help you figure out why it blew a little better and recomend something better....also was the sub a dvc or a svc and how was it wired???....good luck...




  4. #4
    mykeys's Avatar
    mykeys is offline URABUS



    Join Date
    Nov 2001
    Location
    South Prairie, Wa.
    Age
    41
    Posts
    1,057
    Post Thanks / Like
    Mentioned
    0 Post(s)
    speakers dont necessarily blow from a lack of power.. They blow from cranking the volume causing the amp to clip..When an amp clips it cuts off then starts out again with 2to3 times the rated power these power surges are what usually fry your speakers.
    Not to mention the distortion from a clipped signal makes an ungodly sound.

    Mike



    Your friendly neighborhood subaru freak!

  5. #5
    mrmagoo_83's Avatar
    mrmagoo_83 is offline Registered User

    Threadstarter


    Join Date
    Feb 2002
    Location
    Fort Worth, Tx
    Age
    34
    Posts
    102
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Yea, he is one who tends to not head others advice. I beleive (i do not have all the specs for the amp) the amp put a little less than 100Watts RMS, lol. And was probably in clipping 90% of the time. It was wire to a factory GM radio, and dumby always has to listen at full volume. But I think we are gonna toss that amp, or sell it when we start the new system.




  6. #6
    MikeofTulsa's Avatar
    MikeofTulsa is offline The one and Only!



    Join Date
    Feb 2002
    Location
    Tulsa, OK
    Posts
    20,885
    Post Thanks / Like
    Images
    8
    Mentioned
    37 Post(s)
    well before you toss it....drop me a line at Goddyd4me@hotmail.com...i would possibly be interested in getting that from you...heh....




Closed Thread

Similar Threads

  1. need help for a new system?
    By bus45 in forum General Discussion
    Replies: 0
    Last Post: 02-08-2004, 10:48 PM
  2. need help for choosing system...
    By jackson1432 in forum Subwoofers
    Replies: 1
    Last Post: 03-07-2003, 05:23 PM
  3. need help for my girl's system
    By TRDevelopment in forum General Discussion
    Replies: 4
    Last Post: 02-23-2003, 01:44 AM
  4. Need help for first system
    By BNR in forum Subwoofers
    Replies: 1
    Last Post: 01-26-2003, 12:40 AM
  5. 1991 caddy need help for system
    By CaddyLacGrills in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 04-01-2002, 01:31 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum