Closed Thread
Results 1 to 5 of 5

Reload Thread: Not impressed With Germaniums.......Need some crossover tweaking suggestions

  1. #1
    JeffM's Avatar
    JeffM is offline Senior VIP Member



    Join Date
    Jan 2008
    Location
    NL, Canada
    Posts
    294
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Not impressed With Germaniums.......Need some crossover tweaking suggestions

    Before I start, I want to say that the install in not the problem. Doors have 60 square feet of deadener on them, holes are sealed, speakers mounted on MDF rings, etc. The speakers do sound good, but not nearly as good as I think they should be. Right now I have them set at "Reference Soft". What other things should I try changing on the crossover?







  2. #2
    the727kid's Avatar
    the727kid is offline CarAudio.com Veteran



    Join Date
    Jul 2006
    Location
    St. Pete, FL
    Posts
    2,941
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Not impressed With Germaniums.......Need some crossover tweaking suggestions

    What is the xover on your amp or HU? I had my Germs putting some decent midbass out.



    Alarm: Viper 5902
    HU: Stock
    Front Stage:
    Tweeters: Image Dynamics CD1-Pro Mini Horns
    Mids: Sundown Neo Pro 8"
    Subs: (2) 15" Dayton HF ran IB
    Amps: (2) Kicker IX 500.4 (1) Kicker IX 1000.1
    Processor: JBL MS-8

  3. #3
    JeffM's Avatar
    JeffM is offline Senior VIP Member

    Threadstarter


    Join Date
    Jan 2008
    Location
    NL, Canada
    Posts
    294
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Not impressed With Germaniums.......Need some crossover tweaking suggestions

    HPF is set at 100hz on headunit




  4. #4
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,392
    Post Thanks / Like
    Mentioned
    28 Post(s)

    Re: Not impressed With Germaniums.......Need some crossover tweaking suggestions

    You won't get much bass crossing that high. I have my polys at 63Hz. Try 80Hz first and go from there...




  5. #5
    kross's Avatar
    kross is offline CarAudio.com Elite



    Join Date
    Jul 2007
    Location
    Seattle, WA
    Posts
    764
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Not impressed With Germaniums.......Need some crossover tweaking suggestions

    I also have the Germs, and my install is similar (deadened and sealed doors, MDF mounting). Whenever I set the HPF lower than about 120 Hz, the midbass starts sounding muddy and boomy. Not good at all. My sub's LPF is set at 80 Hz. So I have a bit of a gap between 80 and 120 Hz, but it sounds pretty good, just a little weak in the midbass. I was wondering if anyone else has this problem with the Germaniums?



    Thou hath not so much brain as ear wax.

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum