Closed Thread
Results 1 to 15 of 15

Reload Thread: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

  1. #1
    OoMesKoO's Avatar
    OoMesKoO is offline Me > Newbs. :fyi:



    Join Date
    Sep 2005
    Location
    Rhode Island
    Age
    28
    Posts
    3,421
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    Figured before I went and installed my MA Audio HK602SX, my Kicker 350.2, and my Optima Yellowtop... Id throw this out there. I KNOW there are things wrong with it, thats why I posted the pics. But can you guys tell me exactly WHAT it is thats wrong? Id like to get it all fixed before installing anything.

    Onto the pics...

















    All the input the better guys. Help me out. Also, do you guys think 1 optima Yellowtop is enough for a HK602SX and a Kicker 350.2? I know its a class a/b 2ch. High current power HOG...

    But let me know either way!
    Thanks!






    ::References::

    Sold: BIG_SUPERMAN72, biggie5252, Anonymous User, mustangowner
    Traded: poundindak69, perfecxionX, CRXBMPN
    Bought: nismos14, JasonPaul, phoenixgoldfan1, ace 800, ABSOLUTEAUDIO, wu501




  2. #2
    Canaan's Avatar
    Canaan is offline Beatin' the block down



    Join Date
    Mar 2006
    Location
    Monroe, Louisiana
    Posts
    1,491
    Post Thanks / Like
    Mentioned
    3 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    [QUOTE=



    /QUOTE]


    That is one main thing I would change.
    Don't use that seat bracket.

    Ground directly to the frame body.

    A quick and easy way---grind off the paint on an area under the carpet and use self-tapping screws.



    Canaan White...'04 Avalanche
    HU Eclipse 7200MkII
    AMPS DD C4a(front active), 2 DD M2B
    SPEAKERS (Front) DD AT28, DD VO-M65
    SUBS...SOMETHING LOUD SOON!!?
    WIRES XSCORPION
    TEAM SOUTH

    Desiard Street Pawn and Car Audio, Monroe, La...XScorpion and DD Audio Dealer.
    Shop Phone 318-343-8283

  3. #3
    Fiercetimbo17's Avatar
    Fiercetimbo17 is offline CarAudio.com Veteran



    Join Date
    Jan 2007
    Location
    dallas
    Posts
    2,345
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    im very **** but my suggestions are
    new battery terminals, is that red and black cloth holding it on??
    You have no protection for the wires in the engine bay very very bad idea.
    Move your circuit breaker away from the body of the car as those bare ring terminals are dangerously close to the chasis (ground) I would also suggest covering the exposed part of the ring terminals
    Reground your amps to an actual metal chasis part with ring terminals.
    Get a new fused distro block, and is that one just bare metal sitting there?



    Pioneer Avic-z3
    4-way Active
    CDT ES-01
    CDT ES-04
    Dls IR8
    Zapco dc650.6
    12" idmax IB
    zapco dc 1100.1
    tsunami wiring
    200 sq ft edead/damp
    4 gallons spectrum/sludge 160 ft overkill
    132.6 db at 22 hz...


  4. #4
    Lakota's Avatar
    Lakota is offline Doesn't Know $hit



    Join Date
    Feb 2005
    Location
    Louisville, KY
    Age
    26
    Posts
    6,222
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    Use more zip ties and ring terminals.




    Ben Hemp
    1992 GMC Sonoma Ext Cab NEW BUILD
    2008 MECA S1 KY State Champion, 151.0 dB
    2008 MECA S1 WorldChampion, 151.8 dB
    2010 MECA scores: 150.9 dB S2, 151.6 dB S3
    Refs: smd4life, Subst4nce, wccoug21, dacheatham, thegreatestpenn, jshak07

  5. #5
    OoMesKoO's Avatar
    OoMesKoO is offline Me > Newbs. :fyi:

    Threadstarter


    Join Date
    Sep 2005
    Location
    Rhode Island
    Age
    28
    Posts
    3,421
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    Thats it though?

    I thought there was much more than that wrong. I was getting MAJOR current draw with just a BX1500D before!





    ::References::

    Sold: BIG_SUPERMAN72, biggie5252, Anonymous User, mustangowner
    Traded: poundindak69, perfecxionX, CRXBMPN
    Bought: nismos14, JasonPaul, phoenixgoldfan1, ace 800, ABSOLUTEAUDIO, wu501

  6. #6
    headbussaboi's Avatar
    headbussaboi is offline CarAudio.com Elite



    Join Date
    Sep 2006
    Location
    Saint Paul, MN
    Posts
    1,660
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    Looks like you have a pretty long ground going to the rear too. The blue wire. In the second picture, looks like your bolt next to the belt on the alternator isn't screwed in all the way either.




  7. #7
    IgnoreMe's Avatar
    IgnoreMe is offline I love 2 girls 1 cup



    Join Date
    Dec 2003
    Location
    caraudio.com
    Age
    28
    Posts
    11,768
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    that ground is absolutely TERRIBLE



    llllllllllllllll Educate yourself and help stop the ignorance.
    llllllllllllllll DEA Judge Francis L Young says...
    llllllllllllllll Designing a Ported Box


    refs: hazardous0388, snoopdan, karleon, thelow, freezeman_7, imtjnotu, Gebrochen, astroladespl, billabongcr , mustbenu , thunder9500 , 91ser, djdilliodon (6 times), stupify, milenko515, Zeuslicious, Bmoorman05, WaTTsLOk187, too dope 1904, nate2587, rbiele126, denalilvr



    Don't Blame Me. I Voted for Ron Paul.

    BluePoint Air Ratchet for sale...click me bitch

  8. #8
    seg_representin's Avatar
    seg_representin is offline CarAudio.com Elite



    Join Date
    Jul 2006
    Location
    IL
    Posts
    1,085
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    What kinda car is it? If its a ford you might have to ground back to to battery because some fords have a unibody and when its not a good ground when you ground to the frame of the car. Thats what i have to do with my focus.



    2012 Civic Si Sedan

    .:Real playas ride slow loud and bangin:.

  9. #9
    OoMesKoO's Avatar
    OoMesKoO is offline Me > Newbs. :fyi:

    Threadstarter


    Join Date
    Sep 2005
    Location
    Rhode Island
    Age
    28
    Posts
    3,421
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    Quote Originally Posted by OoMesKoO View Post




    In this picture that silver 4awg is a dead line right now, as well as that 0awg run. The distro. goes to that 4awg run which will be going to my MA, and the red piece goes to my 350.2 under the front seat. Then that 4awg blue ground goes to the MA... it is around 3 or 4 feet long, would that have a bad effect on anything?





    ::References::

    Sold: BIG_SUPERMAN72, biggie5252, Anonymous User, mustangowner
    Traded: poundindak69, perfecxionX, CRXBMPN
    Bought: nismos14, JasonPaul, phoenixgoldfan1, ace 800, ABSOLUTEAUDIO, wu501

  10. #10
    casper97ta's Avatar
    casper97ta is offline IM HERE FOR THE GANG BANG



    Join Date
    Jul 2006
    Location
    Pittsburgh, PA
    Posts
    3,459
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    Quote Originally Posted by OoMesKoO View Post
    In this picture that silver 4awg is a dead line right now, as well as that 0awg run. The distro. goes to that 4awg run which will be going to my MA, and the red piece goes to my 350.2 under the front seat. Then that 4awg blue ground goes to the MA... it is around 3 or 4 feet long, would that have a bad effect on anything?

    Put a ring terminal on that wire and do not use that bolt for a ground. Either ground to the frame or do a run to the front battery.



    H.U- Alpine IVA-D310
    clarion EQS746 EQ
    Front stage- PPI 356CS
    Front amp- Exile S400.4
    Sub-
    Sub amp-
    NSB100

    _____________________

    REFS :pimpedout97x,Mike Dressure(x3),hc3_cuz,keefy248,seagrasser,Gammey4,p hillipcyoung,Hawaiian5(x2),Dumpin Treos,delvryboy, xtremebassjunky,All_Rice,AgEnT,96MaxGLE,kurtdirt1, Louisiana_CRX,wu501,REDLINEZ33,vxboi,mrogowski,Zeu slicious,LazyRider



    Quote Originally Posted by cotjones View Post
    you have to admit the equalizers do seem to make 1 watt sound like 2 (1000 watts from a jl sounds way louder than 1000 from an alpine or rockford or many other brands)

  11. #11
    Ignatowski's Avatar
    Ignatowski is offline CarAudio.com Veteran



    Join Date
    Mar 2005
    Location
    Dirty South
    Posts
    6,852
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    its a mess...done like a JrHS kid




  12. #12
    energizedsbs's Avatar
    energizedsbs is offline Senior VIP Member



    Join Date
    May 2006
    Location
    tarpon springs
    Posts
    448
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    imo i would redo everthing but the power wire run...



    just give the dj a break
    where are they hiding...SEDONA

  13. #13
    Frijoles24's Avatar
    Frijoles24 is offline CarAudio.com Elite



    Join Date
    May 2007
    Location
    Los Angeles, CA
    Posts
    571
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    use a ring for the ground. ull tear those individual wires eventually leading to it ripping completly off. and yea dont use the bracket, use the main frame




  14. #14
    edzy's Avatar
    edzy is offline SPL Ninja



    Join Date
    Feb 2007
    Location
    Where you live
    Posts
    2,188
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    why do you have dead runs of power wire ? I would just take them out. And Bat terminals and rings that take the size wire you are using, instead of reducers. And is that alaminium wire off the neg bat? and also that that 0 on the Pos bat terminal, tho it may be tinned copper. And wire loom and zip tie those wire in the engine area.



    Nothing to see here, Move along.

  15. #15
    ngsm13's Avatar
    ngsm13 is offline BSEE



    Join Date
    Sep 2002
    Location
    Cincinnati, OH
    Posts
    35,730
    Post Thanks / Like
    Images
    20
    Mentioned
    0 Post(s)

    Re: Official "Tell me whats wrong with my electrical" Thread.... PICS!!

    Make sure to have a short ground.

    nG




    http://crunktimes.com/ct/
    nG - BSEE

Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum