Closed Thread
Results 1 to 12 of 12

Reload Thread: Just installed MB QUART SUBS in the ride...*pics*

  1. #1
    funkdoktor's Avatar
    funkdoktor is offline Senior VIP Member



    Join Date
    Jul 2007
    Location
    honolulu, hi
    Posts
    291
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Just installed MB QUART SUBS in the ride...*pics*







    I'm thinking about puting it in a sealed enclosure that i'll try and make when i gots the time....this ported will due tho....i'll let you guys know how it sounds like after a day or two of listening different types of music......thanks for checking my stuff out....keep bumpin' guys......peace 0<
    Last edited by funkdoktor; 09-27-2007 at 07:21 PM.



    VEHICLE - 2003 Jaguar X-type 4 door Sedan
    HEAD UNIT - Alpine - IVA - W200 double din
    COMPONENTS - Pioneer - ts-c520prs x4
    SUBWOOFER - 12 Inch Image Dynamics Idmax d-4
    ENCLOSURE - 2.0 cu. ft. @ 30hz
    POWER - Optima Red Top Battery
    Optima Yellow Top Battery
    AMPLIFIERS - Alpine - PDX - 4.150
    Alpine - PDX - 1.1000




  2. #2
    sdmtnbiker420's Avatar
    sdmtnbiker420 is offline GAME 4 SALE



    Join Date
    Mar 2007
    Location
    San Deezy 92111
    Posts
    1,255
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    clean install



    2000 Infiniti QX4 - louder than you
    1989 Honda CRX - faster than you

  3. #3
    bjayjr5679's Avatar
    bjayjr5679 is offline Father of Three



    Join Date
    Nov 2006
    Location
    Columbus, Ohio
    Posts
    897
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    if you get tired of those let me know i have wanted to hear those subs and have one but never had the onions.



    2006 Honda Pilot

    HU: Alpine CDA-9887
    Front Stage: Alpine SPX-177R (waiting to be installed)
    Front Amp: Cerwin Vega EXL 350.2
    SUB: 2 Arc8 d2 (waiting to install)
    Sub Amp: Cerwin Vega EXL 400.4


    CA: Refs
    Sold to:1phatclipse, 02Corvette
    Bought From: 2000lade, dconder, blue200sx, JDBuilder

    DIYMA refs
    Bought from: racing17, sterlingsharp1, joe1
    Sold to:ArcL100, Vash

  4. #4
    bjayjr5679's Avatar
    bjayjr5679 is offline Father of Three



    Join Date
    Nov 2006
    Location
    Columbus, Ohio
    Posts
    897
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    What did you do with the IDMAX



    2006 Honda Pilot

    HU: Alpine CDA-9887
    Front Stage: Alpine SPX-177R (waiting to be installed)
    Front Amp: Cerwin Vega EXL 350.2
    SUB: 2 Arc8 d2 (waiting to install)
    Sub Amp: Cerwin Vega EXL 400.4


    CA: Refs
    Sold to:1phatclipse, 02Corvette
    Bought From: 2000lade, dconder, blue200sx, JDBuilder

    DIYMA refs
    Bought from: racing17, sterlingsharp1, joe1
    Sold to:ArcL100, Vash

  5. #5
    Pimpdaddyq's Avatar
    Pimpdaddyq is offline Owner: Quicks Car Audio



    Join Date
    Apr 2005
    Location
    Clinton Iowa
    Age
    26
    Posts
    2,496
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    yea very simple nice install man.. good work.. hopefully they meet your needs, never messed with MB Quart woofers, definetly post a review..

    Andrew



    Refs: 02Corvette, PsychoTheRapist, Quez82, Fattony911, Megalomaniac, PatFitz9, Twistid, Robertspangler, SPL140.2, hazardous0388, scoob8000, WOT, Rashadd, Tricked - CS.org: TommyTheCat, HawaiianBassHed, MLGreen, Jmanpc..

    Owner: Quicks Car Audio and Detailing in Clinton Iowa

    -- 1995 Honda Civic -- -BlackedOut-
    Black Car, Tinted, Black 17s, 12K HIDs, Black Halo Projector Headlights, and Black Tails...
    Pioneer DEH-P6000UB
    2 Soundstream PCA2000D, 2 Older 15" "Fi Reconed" Immortals 7.5ft^3 at 30hz (SOLD)
    Cheap Kenwood 4ch
    6.5 RSD Components in my Doors
    HO Alt, 1/0 Knu Collossus Wiring, Optima Red In Back

    Xbox Live Gamertag: MistaAPQ

  6. #6
    funkdoktor's Avatar
    funkdoktor is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    honolulu, hi
    Posts
    291
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    Quote Originally Posted by bjayjr5679 View Post
    What did you do with the IDMAX
    i still got it....needs a recone though....the rubber surround and the cone separated during some late night...bass "testing"..lol...i sealed it back up with some type of adhesive glue and it works just fine....looks horrible though...i just can't find anybody here in hawaii that will do the recone....



    VEHICLE - 2003 Jaguar X-type 4 door Sedan
    HEAD UNIT - Alpine - IVA - W200 double din
    COMPONENTS - Pioneer - ts-c520prs x4
    SUBWOOFER - 12 Inch Image Dynamics Idmax d-4
    ENCLOSURE - 2.0 cu. ft. @ 30hz
    POWER - Optima Red Top Battery
    Optima Yellow Top Battery
    AMPLIFIERS - Alpine - PDX - 4.150
    Alpine - PDX - 1.1000

  7. #7
    sqhertz's Avatar
    sqhertz is offline CarAudio.com Veteran



    Join Date
    Sep 2006
    Location
    Miami ,Fl
    Posts
    5,638
    Post Thanks / Like
    Mentioned
    4 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    iirc they do sell a top assembly for idmaxes.





    - Ref.s -
    ssbogger , derek9087 , mike dressure , xluben , brocken , QtrHorse , marley1 , byoon001 , IonSQL , Duke , TheBaron929 , SiX , Andar , blackbonnie , SPLV , dbaudio , dillinja666 , 97cavy , dropkick13 , TeamPSI , foreman , integra88 , bangincaraudio , spinelli , gkatmar , MustangGT25YRS , stockgp , FASTIMES , ultimate157 , Reson8 , vitveet , req


  8. #8
    funkdoktor's Avatar
    funkdoktor is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    honolulu, hi
    Posts
    291
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    Quote Originally Posted by sqhertz View Post
    iirc they do sell a top assembly for idmaxes.
    thanks man...i'll look into that.



    VEHICLE - 2003 Jaguar X-type 4 door Sedan
    HEAD UNIT - Alpine - IVA - W200 double din
    COMPONENTS - Pioneer - ts-c520prs x4
    SUBWOOFER - 12 Inch Image Dynamics Idmax d-4
    ENCLOSURE - 2.0 cu. ft. @ 30hz
    POWER - Optima Red Top Battery
    Optima Yellow Top Battery
    AMPLIFIERS - Alpine - PDX - 4.150
    Alpine - PDX - 1.1000

  9. #9
    funkdoktor's Avatar
    funkdoktor is offline Senior VIP Member

    Threadstarter


    Join Date
    Jul 2007
    Location
    honolulu, hi
    Posts
    291
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    its been about 2 weeks or so listening to these mb quart woofers...i listened to music ranging from rap, r&b and techno............a lot of people said to listen to these subs sealed...but i've bought them from a friend already in a ported box....so my i took the IDMAX out of my trunk so i could pop these in........first impression was........wow. I was expecting this woofer to be more on the SQ side...but to my surprise these things got decently loud...rms on these subs are "only" 500w so i wasn't expecting too much...but i guess since im running two of them with my 1000w pdx's....i guess it was a perfect match for the mb's....bass lines were distinguishable....imaged very well...and again...got decently loud for me.......as for performance in the sealed enclosure.......i put them in a box with 1.5 cu. ft. to each sub.....mb quart recommends .95 each...but my cousin said it was very peaky.....so i opted for 1.5 instead..............................first impression.......nice. Played everything beautifully....punchy..accurate....distinguishable ....and good decay....very pleasing to the ears......didn't get loud like the ported set up but did very respectable....got nice and deep on the low notes too..............all in all.....i rate this sub................VERY GOOD.......not excellent but VERY GOOD....considering the price for one of these woofers...i don't think anyone will be disappointed in the performance...........plays well and it looks clean...........and for my opinion on daily driver box setup...i'd still pick ported...........since these are articulate subs anyway...i didn't lose too much SQ staying with the ported setup........keep bumpin' fellaz.



    VEHICLE - 2003 Jaguar X-type 4 door Sedan
    HEAD UNIT - Alpine - IVA - W200 double din
    COMPONENTS - Pioneer - ts-c520prs x4
    SUBWOOFER - 12 Inch Image Dynamics Idmax d-4
    ENCLOSURE - 2.0 cu. ft. @ 30hz
    POWER - Optima Red Top Battery
    Optima Yellow Top Battery
    AMPLIFIERS - Alpine - PDX - 4.150
    Alpine - PDX - 1.1000

  10. #10
    casper97ta's Avatar
    casper97ta is offline IM HERE FOR THE GANG BANG



    Join Date
    Jul 2006
    Location
    Pittsburgh, PA
    Posts
    3,459
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    Glad you like those man.I've always been curious as to how MB's subs would sound. I expected a real nice SQ woofer from them. Nice install too.



    H.U- Alpine IVA-D310
    clarion EQS746 EQ
    Front stage- PPI 356CS
    Front amp- Exile S400.4
    Sub-
    Sub amp-
    NSB100

    _____________________

    REFS :pimpedout97x,Mike Dressure(x3),hc3_cuz,keefy248,seagrasser,Gammey4,p hillipcyoung,Hawaiian5(x2),Dumpin Treos,delvryboy, xtremebassjunky,All_Rice,AgEnT,96MaxGLE,kurtdirt1, Louisiana_CRX,wu501,REDLINEZ33,vxboi,mrogowski,Zeu slicious,LazyRider



    Quote Originally Posted by cotjones View Post
    you have to admit the equalizers do seem to make 1 watt sound like 2 (1000 watts from a jl sounds way louder than 1000 from an alpine or rockford or many other brands)

  11. #11
    Join Date
    Aug 2007
    Location
    Phoenix, AZ
    Posts
    32
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    thanks man for posting a bit about the MB Quarts. I just bought two of the 8s and have not yet had the time to build the box (hoping to this weekend), but the lack of info about these subs on ca.com was a bit discouraging.

    Others had posted that these don't like ported boxes, but it sounds like you're pretty happy with the way they perform. I'm not going to port my 8s, going with .6cf sealed, but at least it's nice to see these subs get some play.




  12. #12
    Join Date
    Mar 2007
    Location
    saint charles, IL
    Age
    24
    Posts
    10,311
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Just installed MB QUART SUBS in the ride...*pics*

    very nice install bro....




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum