Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 22

Reload Thread: Interesting issue with polk comps and a kicker ZX amp

  1. #1
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...



    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Interesting issue with polk comps and a kicker ZX amp

    Whelp, everything was working just dandy, components sounded awesome, amp was only set at about 1/4 gain (kicker ZX350.2 running Polk momo component set). Then, today i wired in my subs (to a separate amp), and the speakers cut out at high volume (im guessing amps going into protect?) and one of the tweeters doesnt work. I tried turning the gain down, but that doesnt help any (still goes into protect), and i havent looked into the non functioning tweeter yet. It cant possibly be blown, because before i had the subwoofers wired in, the speakers were LOUD. When i wired the subwoofers in is when they started cutting out and the tweeter stopped working, and take note this was at volumes much lower than before.

    Whats got me is these are completely separate. The subs have their own amp, and the comps run off the kicker. Both are powered and grounded to a kinetik 2400, fused, ect. any ideas?



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com




  2. #2
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...

    Threadstarter


    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    bumpskeez



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com

  3. #3
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...

    Threadstarter


    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    ttt, no one?



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com

  4. #4
    troy_audi0's Avatar
    troy_audi0 is offline Top 100 Installer



    Join Date
    Nov 2005
    Location
    Las Vegas, NV
    Posts
    1,195
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    any news?
    Low voltage maybe?
    wire shorting out?
    small bird stuck in the grill?
    keep us posted..



    www.Hybrid-audio.com
    Kenwood Nav
    Hybrid Audio L1 Pro SE, L3, L2x, L6
    Arc10 Ported
    Arc Audio 4200SE (Front Stage 110x4)
    Arc Audio 2150SE (Sub)

  5. #5
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...

    Threadstarter


    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    nope im still at a loss. I dont htink there was a short anywhere, i dont know why there would be. the comps worked perfectly BEFORE the subs were wired into the sub amp. I mean, they screamed. Now, i cant turn em up very loud otherwise they cut out. I can even turn the bass output down to zero and they will cut out at about the same volume.

    My guess was going to be that the BXI was drawing so much from the battery that the kicker wasnt getting sufficient power, causing it to go into protect, but that cant be the case if i can turn the bass level on the deck to zero and i still have the problem, or can it?

    im at a loss



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com

  6. #6
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...

    Threadstarter


    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    oh, and i dont get any voltage drops at all unless im at idle and at high volume



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com

  7. #7
    troy_audi0's Avatar
    troy_audi0 is offline Top 100 Installer



    Join Date
    Nov 2005
    Location
    Las Vegas, NV
    Posts
    1,195
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    you say one of the tweets stopped working too right?
    Is it still off or it is on till "The Vol. Point" of shut down?



    www.Hybrid-audio.com
    Kenwood Nav
    Hybrid Audio L1 Pro SE, L3, L2x, L6
    Arc10 Ported
    Arc Audio 4200SE (Front Stage 110x4)
    Arc Audio 2150SE (Sub)

  8. #8
    SRim23's Avatar
    SRim23 is offline CarAudio.com Veteran



    Join Date
    Jun 2006
    Location
    OH
    Posts
    5,431
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    not sure if there is a way too test it but id look into the problem probably starting at your HU

    i bought my car with momo comps installed in front and rear. Pioneer N1 HU, PA amp giving 150.4 rms to the comps. when i got the car all 4 tweets were blown. i didnt think much of it, just figured previous owner was stupid and played them too loud.

    bought a new set of comps, installed them and as soon as the gain got touched on the amp i got a loud noise through the system. both tweets were fried

    switched HU's, bought new comps and works flawlessly. too N1 in to get checked and it had damaged IC output, open ground(thats what the shop told me at least)

    i am currently running my momo's active with 150rms going to each tweet and for a little over a month i am having zero issues so if that tweet isnt working something serious had to happen to blow it.

    that is if its similar situation as mine. hope that helps.



    sold to : vitveet, ZeroAccess, Regalboi97 bought from: pboulos, mikescanlon, pickup1, konechiwa, CaliforniabOY5, desertheat
    Quote Originally Posted by DDeitz View Post
    blacks buy cars owned by white men who were designed by asians and made by mexicans ...see everyone contributes to the cycle
    Quote Originally Posted by Willkas View Post
    today I was messin with my newly installed subs, i really have no clue what they are but they're definatly old school. Out of nowhere, it burts into awesome mode and starts shaking the garage doors of the entire lot ( work in a auto shop).
    I just want to here some theories how this happened.
    In case you were wondering I drive a tahoe and when I say loud I mean loud to the point that your ears will pop and it starts hurting.

  9. #9
    tru_44's Avatar
    tru_44 is offline CarAudio.com Elite



    Join Date
    Aug 2006
    Location
    sc
    Posts
    549
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    maybe something went bad and changed the ohm load



    planet audio fu-15

    ma audio parametric eq

    eclipse cd4000 headunit

    ma audio synergy HC2501 mono block

    MA Coax

    kinetik battery

  10. #10
    95BlackGA's Avatar
    95BlackGA is offline CarAudio.com Veteran



    Join Date
    May 2007
    Location
    Missouri
    Posts
    4,832
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    5 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    Possible ground connection? Using same grounding point for both amps?



    Sold To - Ku-Sama - Benilson09 X2 - Vitveet - Max_Power X2 - xfeat - DaveT - uglydimple12 - pickup1 - EnvEe 02 - blackbonnie - lightningbolt44 - Louisiana_CRX X2 - audiobahnuser18 - NoPh33rRaCiNg - profoundwill - Scoobydoo - joe98chevy - theMessenja44
    Traded With - Rich00 - fwb_1234 - SPL140.2 - Six501 - Scoobydoo
    Bought From - RoLLaxPhile - SPL140.2 X2 - Randy Savage - Johnny Law.Lulz

    R.I.P Uncle Scot, you'll be missed. 8/22/08 We love you, bud.

  11. #11
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...

    Threadstarter


    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    Quote Originally Posted by troy_audi0 View Post
    you say one of the tweets stopped working too right?
    Is it still off or it is on till "The Vol. Point" of shut down?
    one of the tweeters is completely off (i think i may have pulled the connection loose while putting my door panels back on though, so it very possibly could have been loose and the vibrations just finished it off, i havent had a chance to check yet). the other tweeter and both mids are what shut off at a certain volume



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com

  12. #12
    Supergumby5000's Avatar
    Supergumby5000 is offline Project: F350 begins...

    Threadstarter


    Join Date
    Sep 2005
    Location
    Pullman, WA
    Posts
    8,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    17 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    Quote Originally Posted by 95BlackGA View Post
    Possible ground connection? Using same grounding point for both amps?
    both amps are grounded to battery



    .
    Project: Avalanche V1... http://www.caraudio.com/forum/showthread.php?t=345189
    Project: Avalanche V2... http://www.caraudio.com/forum/showthread.php?t=432321
    Project: F350... Coming Soon!
    .
    Need a box or box design? -EMAIL- me for info/quotes, do NOT send a PM
    my username @ hotmail.com

  13. #13
    zthumper's Avatar
    zthumper is offline Don't call it a comeback



    Join Date
    Jun 2006
    Location
    MW
    Age
    25
    Posts
    1,647
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    2 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    fvcking zx's....send that b*tch back...it's trashed



    02 rsex
    -Type R 15 in 3.5 cubes @ 32hz
    -Kicker zx750.1
    -Pioneer DEH-P5100UB
    -****** stock front stage

  14. #14
    reed dollaz's Avatar
    reed dollaz is offline CarAudio.com Veteran



    Join Date
    Apr 2007
    Location
    Ocala, FL
    Age
    29
    Posts
    2,750
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    hm



    S.O.U.N.D Q.U.A.L.i.T.Y

    HU: Eclipse CD4000
    Front stage amp: Eclipse EA2000
    EQ: Clarion 7 band. EQS
    Front components: Digital Designs DDC6.5
    Rear: Dayton DC 6 1/2 midbass IB
    Rear amp: TBD

    Refs; (SOLD to, Caraudio.com) sgdenny, coolahan, bow125106, killahbean, nismos14
    Boughtfrom; Bjfish, JimJ



  15. #15
    Trey803's Avatar
    Trey803 is offline GAMECOCKS



    Join Date
    Jan 2006
    Location
    SC
    Posts
    5,637
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    29 Post(s)

    Re: Interesting issue with polk comps and a kicker ZX amp

    do u have a light bulb in your crossover if so check to see if its blown.



    HU: DEH-80PRS
    Doors Deadened
    Front Stage: Rainbow SLC 265
    Front Stage Amp: Image Dynamics i2600
    Sub: Dayton RSS210HF-4 8"
    Sub Amp: Image Dynamics i2300
    Wire: Knu

Closed Thread
Page 1 of 2 1 2 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum