User Tag List

Closed Thread
Results 1 to 5 of 5

Reload Thread: Thoughts on Audiocontrol's Epic 150

  1. #1
    Ynot's Avatar
    Ynot is offline Member



    Join Date
    Dec 2001
    Location
    New Jersey
    Age
    34
    Posts
    86
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thoughts on Audiocontrol's Epic 150

    I am considering buying an Audiocontrol Epic 150 and would like to know what everyone thinks about them ? Let me know if it would help or hurt my system .

    I have the following:
    Clarion DXZ715 H.U.
    Alpine 6 1\2 coaxials ( Ft.Doors)
    Clarion 4X6 plates (Rear Pillars)
    2 MTX T6000 subs (In reg. sealed truck style boxes)
    Rockford Punch 800.2 amp

    I am looking for all info on the subject good, bad , or indifferent .
    Thanks



    Tony's 1998 RCLB C1500
    4/6 drop on 20's
    http://www.cardomain.com/id/ynot80




  2. #2
    Merlin 331's Avatar
    Merlin 331 is offline Junior Member



    Join Date
    Feb 2002
    Location
    Georgia
    Posts
    17
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    the good thing about the epic 150 is its line driver out i think its a 9.5 V non-clipping signal that it sends to your amps RCA's. also it gives you some added control of your subs. plus the read out is good for tweaking systems. I have never had any problems with Audio Control also the sub sonic filter will say your subs and your amp will not waste juice on fequencies you can't hear




  3. #3
    Ynot's Avatar
    Ynot is offline Member

    Threadstarter


    Join Date
    Dec 2001
    Location
    New Jersey
    Age
    34
    Posts
    86
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Merlin 331 Thanks for the info . I am glad to hear good things about it . Does anyone else have info on this subject ? The more info the better

    Thanks



    Tony's 1998 RCLB C1500
    4/6 drop on 20's
    http://www.cardomain.com/id/ynot80

  4. #4
    01price's Avatar
    01price is offline Senior VIP Member



    Join Date
    Jan 2002
    Location
    TEXAS
    Age
    30
    Posts
    197
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have an epic150 in my dash. The lights are dim on mine for some reason. It is great, it adds lots of deep bass when you want it. The SPL meter is a little strange at low volumes, but it is pretty accurate at high SPL levels and the voltage readout id pretty much accurate all the time. I have a Phoenix Gold Cyclone in my car, so I always have the bass restoration on at the lowest setting cause the cyclone is designed to play the best at around 20 hz and lower, the lowest setting on the epic150 is almost too much for me lol. It's a great product to have and is pretty flashy. Here's a picture of it at night with just my 2 8w3's and no cyclone. http://forums.caraudio.com/vb/showth...?threadid=2128 and this one is it in the day time:
    Attached Thumbnails Attached Thumbnails Thoughts on Audiocontrol's Epic 150-small-daydash.jpg  




  5. #5
    Ynot's Avatar
    Ynot is offline Member

    Threadstarter


    Join Date
    Dec 2001
    Location
    New Jersey
    Age
    34
    Posts
    86
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Mounting the epic 150

    01price I see you got it mounted under your H.U. was that hard to do ? Also is there a mounting kit to mount it like that ? I am looking at my H.U. and I think it might be a little tight getting both in there . Thanks for the info . Maybe by the summer I will have enough extra cash to pick up one .



    Tony's 1998 RCLB C1500
    4/6 drop on 20's
    http://www.cardomain.com/id/ynot80

Closed Thread

Similar Threads

  1. AudioControl EPIC 150....
    By mgaidica in forum General Discussion
    Replies: 16
    Last Post: 02-15-2003, 06:37 PM
  2. Installing an AudioControl Epic-150 & Four.1
    By james33440 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 10-31-2002, 02:47 PM
  3. Installing an AudioControl Epic-150 & Four.1
    By james33440 in forum General Discussion
    Replies: 6
    Last Post: 10-30-2002, 05:08 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum