Closed Thread
Results 1 to 5 of 5

Reload Thread: Rsd65CS installed and not impressed

  1. #1
    itzme218's Avatar
    itzme218 is offline Senior VIP Member



    Join Date
    Oct 2004
    Location
    bay area
    Posts
    223
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Rsd65CS installed and not impressed

    So heres my setup.
    H/U : Pioneer DEH-P7600MP
    Front Speakers : PG RSD65CS
    Front Speaker Amp : Pioneer GM-6200F (150w RMS x 2 channel 4ohms)
    Sub: Kicker 15"L7
    Sub Amp: Directed D2400 (1200w @ 1 ohms)
    doors not deadened

    Well I had some pioneer revs components installed before, but I think they were knock offs (ebay) cause the basket and some other things were different. Then I just got the RSDs and installed them, they sound no better than the revs. To me the system just doesn't sound full, it seems like its lacking the mid bass even at full settings with loud off. But I did figure something out while messing with the setup. If I use the "loud" option that the pioneer deck has then the fronts do sound a bit better. Pioneer is just making me not satisfied right now. The amp is probably the weak point of the setup right now. grrrrrr







  2. #2
    JohnnyChuttz's Avatar
    JohnnyChuttz is offline Littering and...



    Join Date
    May 2005
    Location
    Grapevine, TX
    Age
    35
    Posts
    843
    Post Thanks / Like
    Images
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Rsd65CS installed and not impressed

    I used to have the same headunit. I always ran it with the loudness set to high iirc. It sounded better to my ears. Now on my 880PRS it is turned off. What ever sounds best to you is what you should run.

    I would recommend deadening your doors as well, as that is a major weak point in your quest for great midbass.



    99 "The Danger Ranger"
    HU: Pioneer Premier 880PRS
    Comps: Crystal Mobilesound SSCS 6
    Comp Amp: LA S2.500--150w x2
    Sub: Diamond Audio D3 10
    Sub Amp: RF P3001--375w x1

  3. #3
    mlstrass's Avatar
    mlstrass is offline Shaggy DOA



    Join Date
    Jul 2006
    Location
    Illinois
    Posts
    10,527
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1164 Post(s)

    Re: Rsd65CS installed and not impressed

    GF's car has a cheapo Pioneer HU and same here, need the loudness on MID or HI otherwise whole system sounds flat/hollow. 2v pre outs not feeding enough signal I'm guessing.




  4. #4
    Towncar's Avatar
    Towncar is offline CarAudio.com Veteran



    Join Date
    Dec 2005
    Location
    who knows
    Posts
    4,359
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    18 Post(s)

    Re: Rsd65CS installed and not impressed

    Sounds like something is not set up right. the midbass out of this set is tremendous.. Double check your wiring..



    Quote Originally Posted by Terranova View Post
    The gain is set around 750 right now. I need to get together with my buddy and plug his stethoscope in to set it to 1000.
    Quote Originally Posted by infamous_e46 View Post
    Start fcking one of the guys in the *** to make her jealous

  5. #5
    itzme218's Avatar
    itzme218 is offline Senior VIP Member

    Threadstarter


    Join Date
    Oct 2004
    Location
    bay area
    Posts
    223
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Rsd65CS installed and not impressed

    Well there's good bass (from the RSDs) when "Loud" is on mid or high, good enough to rattle the doors, but it just messed up the whole sound system, the sub would not be as flat and the rears (stock 6x9) would sound like sheit, but i could always fade it. Stupid pioneer!




Closed Thread

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum