Closed Thread
Results 1 to 3 of 3

Reload Thread: My head unit works but keeps blowing fuses, i need help

  1. #1
    bigjon16's Avatar
    bigjon16 is offline Junior Member



    Join Date
    Jan 2002
    Location
    St. Charles Illinois
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    My head unit works but keeps blowing fuses, i need help

    I recently installed a new Jensen MP3510 head unit in my 91 eclipse but i keep blowing a 10 amp fuse that controls the lighting on my dash. I need some help, is there something wrong with the wiring, please help any suggestions welcomed. Thanks.







  2. #2
    gregj9's Avatar
    gregj9 is offline Member



    Join Date
    Jan 2002
    Location
    florida
    Age
    40
    Posts
    136
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    well I tried to reply to this question a min ago but it didn't post so here it goes again. What you may have done if in fact you used the cut and splice method of installation rather than using a harness, the wire you are using as a ground may be the dash illumination. If this is the case if you probed the wire with a meter, it wouldn't show anything untill you flipped the lights on. Does the fuse blow when you turn the lights on at night?? If so find yourself a good ground for your radio



    96 honda passport

    eclipse head (55040)<br />jl audio 500/5<br />Infinity kappa separates up front<br />4 eclipse 10"<br />audio control esp2 center stage processor

    soon to come: Eclipse mids and highs upgrade<br />e-comm module<br />nav system

  3. #3
    Caveman's Avatar
    Caveman is offline Junior Member



    Join Date
    Dec 2001
    Posts
    12
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)
    Go to your local car stereo dealer and ask them to help. I had the same problem after i got my system installed,so I went back to the dealer and they fixed it for me. That is my suggestion




Closed Thread

Similar Threads

  1. head unit keeps blowing fuses!!!
    By kenwood audio in forum Head Units
    Replies: 1
    Last Post: 04-03-2008, 07:07 PM
  2. My Sub amp keeps blowing fuses???
    By LowRydr in forum General Discussion
    Replies: 3
    Last Post: 03-05-2004, 03:07 PM
  3. My Sub amp keeps blowing Fuses???
    By LowRydr in forum Subwoofers
    Replies: 5
    Last Post: 03-05-2004, 02:49 PM
  4. cd player keeps blowing fuses
    By benelson06 in forum Wiring, Electrical and Installation Help
    Replies: 2
    Last Post: 02-15-2003, 05:55 AM
  5. Head Unit works but keeps blowing fuses
    By bigjon16 in forum Wiring, Electrical and Installation Help
    Replies: 4
    Last Post: 03-12-2002, 01:24 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum