Closed Thread
Results 1 to 6 of 6

Reload Thread: Antishock probs...

  1. #1
    Eddiewould's Avatar
    Eddiewould is offline Junior Member



    Join Date
    Dec 2001
    Location
    Wellington, New Zealand
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Antishock probs...

    Hey guys... I'm not really experienced with the car audio scene yet... but I'm getting into it...

    Anyway at the moment I have a (I know its old and ****) SONY CDX-5090 CD head... replacing it is not an option for now... because I have little money and want to buy an amp/sub first... So I was wondering if you guys cud help me with it?

    Well the problem is it doesn't like playing CDR's very much at all... it'l play them but it skips a LOT... and regular (pressed) CD's aren't much better... Anyway I was wondering if there is anything I can do to improve the antishock, or how much its likely to cost to repair...

    I really don't wanna have to take it out, replace it with a tape head and a carkit...c u!

    ED <img src="eek.gif" border="0">







  2. #2
    mykeys's Avatar
    mykeys is offline URABUS



    Join Date
    Nov 2001
    Location
    South Prairie, Wa.
    Age
    41
    Posts
    1,057
    Post Thanks / Like
    Mentioned
    0 Post(s)
    do you have the support strap attatched to the rear of the deck? I usually don't but can make a world of difference..if it's a really old deck then it may not read cdrs worth a crap anyway..Don't know whatelse you could do.

    Mike



    Your friendly neighborhood subaru freak!

  3. #3
    <jaylee>'s Avatar
    <jaylee> Guest



    I'd say it needs to be suspended by a strap or something of the like and try using a lens cleaner in the deck.<br />If that doesn't work i think your first priority is a new deck. If its skipping now I can only imagine what it'll be like when you put some bass vibes in it.




  4. #4
    Eddie Forcefed's Avatar
    Eddie Forcefed Guest



    support Strap?

    Hey guys... 'w hats a support strap? coz i took the thing out the other day to connect the RCA's to my amp
    and there was no 'strap'...
    if i need one, are they 'generic' (one size fits all headunits) and how much do they cost?

    thanks for your help!




  5. #5
    Join Date
    Jan 2002
    Location
    Brandon, Manitoba, Canada
    Posts
    44
    Post Thanks / Like
    Mentioned
    0 Post(s)
    It's a metal strap between3-7inches long about 1/4"-3/4" wide with numerous holes in it, it is mounted to the chassis of the head unit, and screwed to the car, used for supporting the head unit.



    IASCA certified judge
    competitor novice 1-600

  6. #6
    Join Date
    Jan 2002
    Location
    Brandon, Manitoba, Canada
    Posts
    44
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Oh also, If you didn't get one with your deck, go to a car audio shop around town, if they don't give you one, it'll cost you like2-3 bucks max.



    IASCA certified judge
    competitor novice 1-600

Closed Thread

Similar Threads

  1. HELP!! nasty probs with JL [Zane]
    By tgkx in forum Subwoofers
    Replies: 8
    Last Post: 04-16-2002, 07:16 PM
  2. Probs. w/ Aiwa HU/kenwood amp
    By IowaBoomer in forum General Discussion
    Replies: 0
    Last Post: 02-25-2002, 03:39 PM
  3. Probs. w/ Aiwa HU/kenwood amp
    By IowaBoomer in forum Amplifiers
    Replies: 0
    Last Post: 02-25-2002, 03:35 PM
  4. Probs. w/ Aiwa HU/kenwood amp
    By IowaBoomer in forum General Discussion
    Replies: 0
    Last Post: 02-25-2002, 03:34 PM
  5. Probs with Aiwa cd player/kenwood amp
    By IowaBoomer in forum Wiring, Electrical and Installation Help
    Replies: 0
    Last Post: 02-25-2002, 01:02 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum