Closed Thread
Results 1 to 4 of 4

Reload Thread: Polyfill needed for 10" cvx?

  1. #1
    Join Date
    Jun 2012
    Location
    Missoula, MT
    Posts
    91
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    44 Post(s)

    Polyfill needed for 10" cvx?

    So learning more about car audio little by little, and I always like to tweak my stuff to the best it can be. I read a little bit about polyfill and how it simulates a larger box by slowing down bass waves. I tried it once before, but i remember it really seemed to decrease my spl and some of the bass notes just didn't sound right to me so I took it out. However, this was back when I was a noob and had my gains set wrong and my bass boost way up. I've now got good amps that are set right so kind of want to experiment again. Current set up is 10" kicker cvx powered by alpine mrp-450 pushing 400 watts at 2 ohms. It is in a slit ported enclosure and I think its max size it can take (1.75 cu ft.) but not sure. I'll need to measure to confirm. So i love the sub, box and amp combo and it hits hard for a 10. Guy at my local car audio shop thought it could hit 130's. I'm becoming more of a sound quality guy than spl and been really interested in box designs. Not looking to spend the money and have a custom box built just yet, but ive been hearing a big sealed enclosure sounds way better than ported. Would like to try a sealed sometime, but how does a ported sound with polyfill? How much should I add? If my box is built to max volume the sub can handle is polyfill needed? Will it hurt the sub? How damaging is constantly taking out and putting back in a sub to the box? Should I drill into the same screw holes or put in different ones?







  2. #2
    frogcase2002's Avatar
    frogcase2002 is offline CarAudio.com Elite



    Join Date
    Dec 2011
    Location
    hamilton, ohio
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    101 Post(s)

    Re: Polyfill needed for 10" cvx?

    I'm pretty sure that Polly is mostly used for sealed boxes. I wouldn't bother with it if I was you....and if you are liking the loudness of your ported box you will probley not want to go sealed. and you will probley end up stripping the screw holes if you take it out a lot. Look up t-nuts




  3. #3
    audiobaun's Avatar
    audiobaun is offline Premium Member audiobaun is a Supporting Member of the forum!



    Join Date
    Jun 2011
    Location
    rockwall,Tx
    Posts
    6,585
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    1409 Post(s)

    Re: Polyfill needed for 10" cvx?

    If you put PolyFill in that Ported box..lol you will have that chit all over the vehicle in little pieces/use in a sealed enclosure only.Build a spec made enclosure,in which you are at it max by specs of 1.75 is what I found, but you honestly need some power for that sub,that Alpine amp is ok, but consider more power for that sub,get it moving more,and another question would be..what coil configuration is the sub woofer?DVC4 ohm, or DVC2ohm, or DVC8ohm?And what vehicle is it in makes a big difference of sub woofer location as well.




  4. #4
    ladysmanfelpz's Avatar
    ladysmanfelpz is offline Member

    Threadstarter


    Join Date
    Jun 2012
    Location
    Missoula, MT
    Posts
    91
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    44 Post(s)

    Re: Polyfill needed for 10" cvx?

    DVC4 ohm wired to 2 ohms. In subaru legacy with port side on drivers side firing backwards.




Closed Thread

Similar Threads

  1. 500-800 Rms needed for 10" type r
    By Albyint in forum Amplifiers
    Replies: 6
    Last Post: 04-18-2008, 06:28 AM
  2. Is polyfill needed for a correct box?
    By bchandler in forum Subwoofers
    Replies: 0
    Last Post: 07-15-2007, 05:31 PM
  3. Need input on enclosure for 10" Punch HX2
    By jiggy2dmax in forum Subwoofers
    Replies: 3
    Last Post: 02-21-2005, 09:45 PM
  4. What amp do i need for 2 10" Eclipse Aluminums
    By HarleyF150 in forum Amplifiers
    Replies: 4
    Last Post: 10-26-2002, 06:33 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum