Closed Thread
Results 1 to 13 of 13

Reload Thread: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

  1. #1
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member



    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Icon8 Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Ok, so I've had my Viper 5900 security system installed for about a year or two. I have gone through two 515R's and am now trying to install my new 511T "super loud" siren. The 511T siren comes with 4 wires (red, black, purple, and blue) whereas the 515R has another 4 wires (red, black, purple, and green).

    The problem:
    It all happened after I replaced the first one that died mysteriously. I bought another 515R and installed it. Problem solved...for a few months. I replaced my car battery and about a month later the siren just randomly starting going off. It had been going off for a while I think, cause when I went out to my car, the siren sounded like a dying cat. My car started right up first time, so I just figured it was a dud battery. Later my car battery died and had to be replaced

    I go to install my new siren today and see that the new siren has a blue wire instead of the green wire that is in the wiring harness.

    The question:
    Why did two of my 515R sirens die?
    &
    How do I wire the new siren?







  2. #2
    THUNDERBIRD's Avatar
    THUNDERBIRD is offline CarAudio.com Veteran



    Join Date
    Feb 2005
    Location
    LANSING, MI
    Posts
    2,316
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    i will look into it at work but i would start with trying the red and black. what are the purple and green currently hooked up to? to me it would seem like hook purple to purple and blue to green.



    94' thunderbird *parked*<
    4.6 V8 with a shift kit
    clarion dxz 645mp clarion sirius tuner
    ED 6000v.2- front jbl 5.25 comps- rear
    dynamated and edeaded trunk lid, rear deck, front doors
    Big 3 in green of course
    viper 791xv w/ battery backup
    3 jl 10w0
    2000 ford ranger supercab 3.0v6 4x4
    stock hu
    alpine mrp-m350
    2 9kv.3's
    clifford matrix rsx 50.5x
    spring time getting clarion MAX675VDII and front components possibly jbl's again

  3. #3
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Quote Originally Posted by THUNDERBIRD View Post
    i will look into it at work but i would start with trying the red and black. what are the purple and green currently hooked up to? to me it would seem like hook purple to purple and blue to green.
    That's exactly what I did. I'll have to look into it further after work.




  4. #4
    qkassidyw's Avatar
    qkassidyw is offline MECP Master Certified



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    443
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    I have seen plenty of those backup battery sirens go bad; don't know why but they all seem to do the same thing, go off randomly and drain the cars battery.

    Luckily mine hasn't though

    Oh, and great choice of color on your car



    07 F150 Extended Cab FX2 Sport
    Kenwood KDC-BT945U - And that's about it...

  5. #5
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Quote Originally Posted by qkassidyw View Post
    I have seen plenty of those backup battery sirens go bad; don't know why but they all seem to do the same thing, go off randomly and drain the cars battery.

    Luckily mine hasn't though

    Oh, and great choice of color on your car
    Thank you, you too!




  6. #6
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Looked at the installation guide last night for my alarm. Didn't really help me too much.




  7. #7
    qkassidyw's Avatar
    qkassidyw is offline MECP Master Certified



    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    443
    Post Thanks / Like
    Images
    5
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Quote Originally Posted by AW_STi06 View Post
    Looked at the installation guide last night for my alarm. Didn't really help me too much.
    The info for the siren would be under the sirens manual.

    Im pretty sure its:

    red - 12 volts
    balck - ground
    purple - positive siren output (brown from alarm)
    green - negative siren output (used for other alarms)



    07 F150 Extended Cab FX2 Sport
    Kenwood KDC-BT945U - And that's about it...

  8. #8
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Quote Originally Posted by qkassidyw View Post
    The info for the siren would be under the sirens manual.

    Im pretty sure its:

    red - 12 volts
    balck - ground
    purple - positive siren output (brown from alarm)
    green - negative siren output (used for other alarms)
    I did that and now my viper fob won't communicate with the car alarm. Do I need to re-program or reset my alarm?




  9. #9
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    I just re-read your post after talking to someone in Canada with DEI (who of course doesn't have the wiring diagram) and noticed that you both mention the brown wire. Here is what he had to say.

    "The green wire from the security system is the negative door trigger input wire.
    The only siren output from the security system is the brown wire and it's a positive signal.
    I don't have the 511T wiring guide to help you."

    I don't have a brown wired output. I only have the red, black, green, and purple. No brown.




  10. #10
    JKBengali's Avatar
    JKBengali is offline Patton's Prodigy



    Join Date
    May 2009
    Location
    Oxford, AL
    Posts
    2
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Quote Originally Posted by qkassidyw View Post
    The info for the siren would be under the sirens manual.

    Im pretty sure its:

    red - 12 volts
    balck - ground
    purple - positive siren output (brown from alarm)
    green - negative siren output (used for other alarms)
    This is correct. The brown wire in question comes off of the alarm, not the siren. On the siren, hook the red to constant, black to ground. Run your brown siren output wire from the dei alarm to the purple wire coming out of the siren. Tape off the green wire, problem solved. Funny I have one of these things and was trying to hook it up today lol. Im not so sure of that 511t for the model # as I cant find any info for it online. I do know its one helluva siren. My question is what do I need to do to make it work constantly on my factory alarm horn that blows intermittently. Surely theres some delay relay or something I could build to put on it. Any ideas????




  11. #11
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Quote Originally Posted by JKBengali View Post
    This is correct. The brown wire in question comes off of the alarm, not the siren. On the siren, hook the red to constant, black to ground. Run your brown siren output wire from the dei alarm to the purple wire coming out of the siren. Tape off the green wire, problem solved. Funny I have one of these things and was trying to hook it up today lol. Im not so sure of that 511t for the model # as I cant find any info for it online. I do know its one helluva siren. My question is what do I need to do to make it work constantly on my factory alarm horn that blows intermittently. Surely theres some delay relay or something I could build to put on it. Any ideas????
    The problem is that I have no brown wire to hook up to.

    Last edited by AW_STi06; 05-12-2009 at 11:38 AM.




  12. #12
    Proximity's Avatar
    Proximity is offline CarAudio.com Veteran



    Join Date
    Apr 2008
    Location
    Detroit
    Age
    24
    Posts
    2,269
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Look at your alarm installation manual. Look for the siren output. If it's a + output, connect that to the purple wire on the siren, if it is negative, connect it to the green wire. It's not difficult.




  13. #13
    AW_STi06's Avatar
    AW_STi06 is offline Junior Member

    Threadstarter


    Join Date
    Mar 2009
    Location
    ATX
    Posts
    8
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Viper 5900 w/ 515R Siren -> 511T Siren (PROBLEM)

    Grrrr. I am sorry that I am not electrician savvy.




Closed Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts

1e2 Forum