Closed Thread
Results 1 to 2 of 2

Reload Thread: Problems with Car stereo

  1. #1
    Grimey's Avatar
    Grimey is offline Junior Member



    Join Date
    Aug 2011
    Location
    Kissimmee, Florida
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Problems with Car stereo

    Aight.. I really didnt see another place to put this so.. I'm posting it here since this is about repairs and stuff.

    Well.. the other day.. I was driving in my 98 V6 Mustang and I went over a speed bump real slow and the bottom of my car hit the bump. All was functional. I turned off the car to see if I had damaged my exhaust pipe cause it had previously been loosened (I fixed that). All was fine, but when i turned on my car.. my stereo wouldn't turn on. I got home and checked the radio... Wiring was connected correctly. ALL Fuses were all good (Tested em with a fuse tester). Fuses included the Radio fuse.. the fuses under my steering wheel and the fuses under the hood and all was functional. I Redid all the wiring and noticed that my amp didn't turn on either. So, I thought I may of blew the stereo itself.. I got my factory stereo that worked perfectly fine before and hooked it up and to my surprise, it wouldn't turn on either. When I turned on my headlights the lights on my factory stereo turned on but no buttons worked or anything. I hooked up my other stereo again and noticed it made a sound (like it was turning on) when I plugged in the harness. Still didn't work. Then I reset it.. Still nothing. I came to the conclusion that there must be a short or something in the wiring (not including the harness adapter i bought along with my aftermarket stereo) I believe I'd need a test light and check the wiring and replace the shorted wires.. I would really appreciate the help. Sorry for the little essay lol.

    I have a Sony Explod Stereo with the face.
    I have 2, 14 inch Pioneer Subs Hooked up to a Atx Amp (I believe its that one).. and ALL was working for about 6 months.







  2. #2
    Dirtrider4eva's Avatar
    Dirtrider4eva is offline √\_The CaUsE__



    Join Date
    Mar 2011
    Location
    Milwaukee, WI
    Posts
    4,289
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    840 Post(s)

    Re: Problems with Car stereo

    hmm. well if everything else is functioning, it has to be the headunit. maybe when you hit a bump, it messed something internally. if all the wires are correctly intact.
    have you "shaken" the headunit and hear anything rattling around?



    welcome to
    Where b-stock is the new a-stock
    TEAM WEST

Closed Thread

User Tag List

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum