Closed Thread
Results 1 to 5 of 5

Reload Thread: SLOW acceleration in drive

  1. #1
    bigwheel15's Avatar
    bigwheel15 is offline Ooh Yeah!!



    Join Date
    Jan 2004
    Location
    Fort Worth,Texas
    Age
    26
    Posts
    3,767
    Post Thanks / Like
    Mentioned
    21 Post(s)

    SLOW acceleration in drive

    Alright well I have a 1995 jeep Cherokee with an auto trans and since I've owned it I've been noticing something strange. When I put the vehicle into drive it accelerates extremely slow, to the point if im sitting at a light at the bottom of a steep hill it wont make it up.
    However if I take off with the trans down in first it accelerates just fine. Ive checked the trans fluid several times and its okay. I don't know too much about trans so hopefully you guys can help me out.







  2. #2
    KidThump's Avatar
    KidThump is offline V.I.P



    Join Date
    Oct 2006
    Location
    Georgia
    Posts
    1,845
    Post Thanks / Like
    Images
    3
    Mentioned
    0 Post(s)

    Re: SLOW acceleration in drive

    On an automatic transmission, if you do the whole first to second to drive thing alot, it will eventually be a crap tranny and not pull great or just break....

    It could be anything in the drivetrain but you shouldn't expect a jeep to go fast anyway....



    01 Jeep Grand Cherokee Laredo
    JVC KD-S26- AP 100.2-AP 1500d

  3. #3
    bigwheel15's Avatar
    bigwheel15 is offline Ooh Yeah!!

    Threadstarter


    Join Date
    Jan 2004
    Location
    Fort Worth,Texas
    Age
    26
    Posts
    3,767
    Post Thanks / Like
    Mentioned
    21 Post(s)

    Re: SLOW acceleration in drive

    Quote Originally Posted by KidThump View Post
    On an automatic transmission, if you do the whole first to second to drive thing alot, it will eventually be a crap tranny and not pull great or just break....

    It could be anything in the drivetrain but you shouldn't expect a jeep to go fast anyway....
    I don't regularly shift the trans, I just tried it in first to see if there was a difference and noticed it accelerated normally.

    And I don't expect it to go fast, im talking about it is just ridiculous how slow it accelerates, to the point it cant make it up semi-steep hills from a stop. Ive driven another jeep Cherokee one year newer than mine and it didn't experience the problem im having with mine.

    Im hoping I can just get an idea of what might be the cause or different things I should have checked.




  4. #4
    audioatg's Avatar
    audioatg is offline CarAudio.com Elite



    Join Date
    Aug 2006
    Location
    NJ 08080
    Posts
    1,741
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: SLOW acceleration in drive

    Its most likely the 1-2 shift selonoid has gone bad. The test you did is a good test to find out if its electrical or mechanical. If you can put it down in first gear and take off fine. The trans is okay. There are a couple of other threads on jeeps I have posted in about this some what same problem. Try searching for them....

    Other then that. Doing all the seloniods wouldnt be a bad thing. There are three I think pretty sure on it. Been a few since I did mine. But they dont cost that much if you search online for a trans store.




  5. #5
    audioatg's Avatar
    audioatg is offline CarAudio.com Elite



    Join Date
    Aug 2006
    Location
    NJ 08080
    Posts
    1,741
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: SLOW acceleration in drive

    Quote Originally Posted by KidThump View Post
    On an automatic transmission, if you do the whole first to second to drive thing alot, it will eventually be a crap tranny and not pull great or just break....

    It could be anything in the drivetrain but you shouldn't expect a jeep to go fast anyway....
    I have no problem with my jeep going fast. Or taking off fast.




Closed Thread

Similar Threads

  1. Quick Questions on Amps and Car Acceleration
    By Immortal in forum General Discussion
    Replies: 21
    Last Post: 03-01-2008, 12:09 PM
  2. Acceleration Problems
    By Kimb0 in forum Car Interior/Exterior Enhancements
    Replies: 9
    Last Post: 04-15-2007, 11:39 AM
  3. Studder/delay on hard acceleration
    By SwaveY in forum Car Performance and Repair
    Replies: 5
    Last Post: 09-10-2006, 03:46 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum