Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 18

Reload Thread: Crown Vic won't crank!

  1. #1
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite



    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Crown Vic won't crank!

    So I bought my 1995 Crown Vic about 5 months ago. I have never had any problems up until this past month. My car started up fine up until I left my headlights on about a month ago. I cam outside the next morning and tried to jump my car and it just would not crank at all. My uncle replaced the starter and it started up, but then a loud constant clicking noise started suddenly from somewhere under my dash. The car started fine after this but the click never went away. I replaced my battery soon after with a Optima Blue Top because I was getting ready to put my system in. The car was perfectly fine but the clicking did not stop. Just this last weekend I come out of walmart and my car again would not start. I figured my battery was faulty. I asked a guy to give me a jump and he tested my battery and said it was fully charged. He then crawled under my car and bypassed something with a screwdriver. My car started right up but he said my car would not crank over again as soon as I turned it off. Now I am here with a Crown Vic that won't crank. I did some searching on the web and I think it might be my ignition switch, Solenoid, or my safety switch. I have no idea. Any help guys?



    Lanzar OptiDRIVE




  2. #2
    Blasphemy's Avatar
    Blasphemy is offline Boss Mode ☑On ☐Off



    Join Date
    Apr 2010
    Location
    Taylor, MI/Delphos, OH
    Age
    25
    Posts
    396
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Probably the starter solenoid.




  3. #3
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Quote Originally Posted by JCiarlino View Post
    Probably the starter solenoid.
    Thanks for the reply. Any idea as to the constant clicking noise under the dash?



    Lanzar OptiDRIVE

  4. #4
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    ttt



    Lanzar OptiDRIVE

  5. #5
    Databyter's Avatar
    Databyter is offline Member



    Join Date
    Apr 2010
    Location
    San Diego
    Posts
    109
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Agree it's the solenoid, or possibly the starter relay if your car has one, but 90% solenoid.

    As far as the clicking, sounds like you need to have someone who knows about cars to look into that, but it could have been the solenoid even then if it was shorting or failing somehow, it may have just sounded like it was under your dash.

    If it is under there then don't be surprised when your car catches on fire one day.

    Have a mechanic look at it when it's making the noise.




  6. #6
    Blasphemy's Avatar
    Blasphemy is offline Boss Mode ☑On ☐Off



    Join Date
    Apr 2010
    Location
    Taylor, MI/Delphos, OH
    Age
    25
    Posts
    396
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    I am pretty sure the solenoid is on the firewall, that might be why it sounds like it's coming from under your dash. What year is your Vic?




  7. #7
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Quote Originally Posted by JCiarlino View Post
    I am pretty sure the solenoid is on the firewall, that might be why it sounds like it's coming from under your dash. What year is your Vic?
    95.



    Lanzar OptiDRIVE

  8. #8
    Blasphemy's Avatar
    Blasphemy is offline Boss Mode ☑On ☐Off



    Join Date
    Apr 2010
    Location
    Taylor, MI/Delphos, OH
    Age
    25
    Posts
    396
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Advice: The most common indication of a bad starter solenoid or starter relay is a rapid clicking noise whenever the ignition switch is turned to the crank position. This condition can also be caused by low battery voltage or high resistance caused by loose or corroded battery cables and / or connections.

    ^ Found that on AutoZone.com

    A new one is 11.99 there.
    Last edited by Blasphemy; 04-28-2010 at 09:09 PM. Reason: Added price.




  9. #9
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Quote Originally Posted by JCiarlino View Post
    Advice: The most common indication of a bad starter solenoid or starter relay is a rapid clicking noise whenever the ignition switch is turned to the crank position. This condition can also be caused by low battery voltage or high resistance caused by loose or corroded battery cables and / or connections.

    ^ Found that on AutoZone.com
    Nice man. Thank you so much. I am going to check the cables and the starter solenoid.



    Lanzar OptiDRIVE

  10. #10
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    UPDATE! I checked the wires that run from my positive battery terminal to the starter. They were pretty tore up and corroded. I sprayed some WD40 and tightened the wire. It started right up! :] However the clicking noise is still there. Should I go and buy a new power wire?



    Lanzar OptiDRIVE

  11. #11
    Blasphemy's Avatar
    Blasphemy is offline Boss Mode ☑On ☐Off



    Join Date
    Apr 2010
    Location
    Taylor, MI/Delphos, OH
    Age
    25
    Posts
    396
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    That will help, but I would get a new solenoid also to be on the safe side.




  12. #12
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Quote Originally Posted by JCiarlino View Post
    That will help, but I would get a new solenoid also to be on the safe side.
    Is it easy to replace a solenoid?



    Lanzar OptiDRIVE

  13. #13
    Blasphemy's Avatar
    Blasphemy is offline Boss Mode ☑On ☐Off



    Join Date
    Apr 2010
    Location
    Taylor, MI/Delphos, OH
    Age
    25
    Posts
    396
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    No. Just a couple wires and a couple bolts and you'll be set.




  14. #14
    Sir Swish's Avatar
    Sir Swish is offline CarAudio.com Elite

    Threadstarter


    Join Date
    Apr 2010
    Location
    Nebraska
    Posts
    537
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    0 Post(s)

    Re: Crown Vic won't crank!

    Quote Originally Posted by JCiarlino View Post
    No. Just a couple wires and a couple bolts and you'll be set.
    thanks a **** ton guy. Saved me a bunch of money.



    Lanzar OptiDRIVE

  15. #15
    Louisiana_CRX's Avatar
    Louisiana_CRX is online now dem shoes......



    Join Date
    Aug 2006
    Location
    Piney Hills of Louisiana
    Posts
    34,722
    Post Thanks / Like
    Images
    9
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    660 Post(s)

    Re: Crown Vic won't crank!

    i hope you get it fixed.....




    Current 2010 Louisiana USACi State Records :

    Trunk 0-1000.................. 151.3
    StreetBeat 2................... 145.6
    Stock 1801-up.................153.8
    SuperStock 1801-up..........154.2
    Top three in 11 out of 26 power classes and Louisiana USACi Points Leader at 465

Closed Thread
Page 1 of 2 1 2 LastLast

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum