Closed Thread
Page 1 of 3 1 2 3 LastLast
Results 1 to 15 of 43

Reload Thread: I need of a Car nut.

  1. #1
    Silver's Avatar
    Silver is offline CarAudio.com Veteran



    Join Date
    May 2004
    Location
    Brighton, MI
    Age
    27
    Posts
    2,699
    Post Thanks / Like
    Mentioned
    0 Post(s)

    I need of a Car nut.

    Who's good with the 4.6L SOHC?

    Ok so I have been having a rough idle and surging below 3k rpm untill vehicle warms up, since my CEL is blown (bulb) I got my car scanned at Auto-tards.

    I don't recall the name but it has something to do with the air to fuel mixture causing the rough idle. I also have EGR excessive flow, but I've had that for years now. I've cleaned the channels also.

    Recently I did a harsh (thru shrader valve on fuel rail) fuel injection clean.

    The car idles rough and it feels like there is a dead cylinder when first cold. Intermittently I get a backfire or hear a LOUD pop from my Intake tube. It goes away within one minute.

    When I first start the car it idles fine around 1k rpm. Soon as the IAC adjusts and dips rpm it starts shaking and misfiring away. Then at 1/2 throttle it sounds like a dirty maf would, ect. At WOT the misfire goes away and comes BACK when i let off throttle.

    One thing I do notice. The motor makes a "click" noise and the car runs fine after that like almost something is being stuck shut @ 3/4 or below throttle.

    I have NO IDEA what to do. Could I have killed an injector? If so, what would diagnosis mechanically for a fuel injector be?

    So far I've cleaned my maf, replaced plugs wires, tried another fuel injection clean, checked torque converter (before code was thrown), checked valves (bad guides, burns oil), compression test. Everything check out OK. A long time ago the car had a rough idle and my pops messed with the set screw on the throttle body (this was 3-4 years ago). I dunno if the ATF mixture is incorrect now.

    This problem is bugging me pretty bad now, because I was leaning towards fuel injectors untill that code was thrown.

    Please help!!!



    http://www.caraudio.com/forums/signaturepics/sigpic14041_2.gif
    07 Jeep GC - Viper reps / afe stage 2 / chipped / h&r lowering springs

    Stock stereo




  2. #2
    LoudCrownVic's Avatar
    LoudCrownVic is offline 1/1 of Team Team Team



    Join Date
    Dec 2003
    Location
    Scales Bump, IL
    Age
    29
    Posts
    6,122
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    Wow, ***** to hear the probs you are having wit your tbird.

    I'd say that given the problems I had with my Crown Vic, it's quite possibly an electronic issue.

    You might have to replace the Mass Airflow Sensor.

    The only problem i remember I had in my Crown Vic when the MAFS went out was strange throttle response, mind you.

    I have no idea how you would check it but I assume that there is changing impendance or voltage that moves through the wires from the sensor as the airflow changes, stable at idle. Whle the car sits at idle and your voltmeter/ohmeter is bouncing or eratic, you could have your problem right there. Of course I will stress again that have no idea how you are really supposed to check the MAFS, you will want to look that up. The readings from OTHER sensors might affect this one. And MAFS are not cheap. It was like 400 bucks with diagnostics to fix mine. If you do replace it you might as well look into one of those Granitelli motorsports ones that give you a performance boost.

    If the code read as a problematic air fuel mixture, I wouldn't be suprised if this is to blame.

    Another thing that can cause engine bay electronic mayhem in general is bad grounds. Like all those little grounding staps here and there to the body or the block can go bad and cause all kinds of erattic readings. I doubt this is your problem though.



    I com to lern bout car awww-deeeee-ohhhhhs!
    Truck: 1998 Ford Ranger SC 2.5L 4 cyl 5 spd
    Mods- 195/60R15 Cooper Cobra Tires on stock rims
    System: HU- Eclipse CD8454, 2 Dayton RS180 7" midbass, Optimus 3" Horn Tweets hotglued to the dash, 3 12" JL W6v1's downfiring sealed, PPI PCX2200 @ 4 ohms, Alpine MRV-F545 mids and highs, 2 layers of Raamat on the doors.
    What's in Store:
    2 more Dayton RS180 7" midbass, 2 Bolender Grabender Neo planar tweets

  3. #3
    mapolley07's Avatar
    mapolley07 is offline its all imaginary



    Join Date
    Apr 2007
    Location
    Georgetown College, KY
    Age
    25
    Posts
    1,141
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    check your exhaust system too. my dad's grand marquis idles rough with a busted catalytic converter. one of your cats could be busted or blocked. if you have no emissions testing in your area, remove the cat and replace it with flexpipe or straight pipe.



    Quote Originally Posted by captaincheesey View Post
    I don't know because I am blindfolded and tied to the bed. I think I hear the clothes washer in the background sometimes, so maybe she is looking at laundry? Idk

  4. #4
    Ferendon's Avatar
    Ferendon is offline Proabbly drukn



    Join Date
    Jul 2007
    Location
    Fort Worth, TX
    Posts
    950
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    IAC/IAB valve. Very common issue on alot of Fords. That wouldn't be the problem if it continues when you touch the gas, but it might be contributing to the idle problem. MAF sensor is a good place to check, and I'd recommend checking for a fouled plug or 2. The FI cleaning may have been nice and cold, which may have damaged a spark plug, or possibly even an injector.




  5. #5
    Silver's Avatar
    Silver is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    May 2004
    Location
    Brighton, MI
    Age
    27
    Posts
    2,699
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    Update, for the first time it didn't do it at start up. Only difference is it was raining out and very humid. Which is very odd.

    I already looked at the IAC, I don't have a tool reader so I couldn't diagnose if its working properly.

    I think I am going to clean it first. I also am going to replace the EGR valve and the DPFE sensor to clean that code up. I'll report back.



    http://www.caraudio.com/forums/signaturepics/sigpic14041_2.gif
    07 Jeep GC - Viper reps / afe stage 2 / chipped / h&r lowering springs

    Stock stereo

  6. #6
    LoudCrownVic's Avatar
    LoudCrownVic is offline 1/1 of Team Team Team



    Join Date
    Dec 2003
    Location
    Scales Bump, IL
    Age
    29
    Posts
    6,122
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    Good I'm curious to see what happens!



    I com to lern bout car awww-deeeee-ohhhhhs!
    Truck: 1998 Ford Ranger SC 2.5L 4 cyl 5 spd
    Mods- 195/60R15 Cooper Cobra Tires on stock rims
    System: HU- Eclipse CD8454, 2 Dayton RS180 7" midbass, Optimus 3" Horn Tweets hotglued to the dash, 3 12" JL W6v1's downfiring sealed, PPI PCX2200 @ 4 ohms, Alpine MRV-F545 mids and highs, 2 layers of Raamat on the doors.
    What's in Store:
    2 more Dayton RS180 7" midbass, 2 Bolender Grabender Neo planar tweets

  7. #7
    Silver's Avatar
    Silver is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    May 2004
    Location
    Brighton, MI
    Age
    27
    Posts
    2,699
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    Cleaned the IAC, everthing is working good.



    http://www.caraudio.com/forums/signaturepics/sigpic14041_2.gif
    07 Jeep GC - Viper reps / afe stage 2 / chipped / h&r lowering springs

    Stock stereo

  8. #8
    azbass's Avatar
    azbass is offline the salty ca.com mod



    Join Date
    Sep 2004
    Location
    Long Beach, CA
    Posts
    34,922
    Post Thanks / Like
    Images
    6
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    I car nut need of a?




  9. #9
    Silver's Avatar
    Silver is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    May 2004
    Location
    Brighton, MI
    Age
    27
    Posts
    2,699
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    Quote Originally Posted by azbass View Post
    I car nut need of a?
    It was suppoed to say. "In need of a car nut."




    ***.



    http://www.caraudio.com/forums/signaturepics/sigpic14041_2.gif
    07 Jeep GC - Viper reps / afe stage 2 / chipped / h&r lowering springs

    Stock stereo

  10. #10
    Beat_Dominator's Avatar
    Beat_Dominator is offline Yea, thats Mecha Godzilla



    Join Date
    Mar 2005
    Location
    Phoenix Arizona
    Age
    32
    Posts
    21,986
    Post Thanks / Like
    Images
    16
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    First thing that came to my mind was MAF or Oxygen sensor..... but it sounds like you're getting it figured out



    Comming Spring 2009


    I make rear-loaded, double crabshell, isobaric enclosures.

  11. #11
    oglejust's Avatar
    oglejust is offline CarAudio.com Elite



    Join Date
    Jan 2007
    Location
    IL
    Posts
    727
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    egr valve will make it run rough




  12. #12
    blimblam's Avatar
    blimblam is offline CarAudio.com Elite



    Join Date
    Dec 2006
    Location
    new orleans
    Posts
    1,590
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    i got the same problem! people kept telling me thats the problem, IAC valve. what did you use to clean it?



    bought from: dragnix, bk12321 (2x), massiveaudiocw, JDBuilder (2x) (caraudiojunkyard.com), vitveet (2x), Optimus_Prime (ROE), RidnClean, TheGreatMonkey, acex3a, fasfocus00, got_bass89, goindef154, mcv30, d77543020

    sold to: caligirl2k, mike86ttype, fasfocus00

  13. #13
    Silver's Avatar
    Silver is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    May 2004
    Location
    Brighton, MI
    Age
    27
    Posts
    2,699
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    Quote Originally Posted by oglejust View Post
    egr valve will make it run rough


    Correct, espically if the valve is stuck open. Will cause a lean condition.

    I'm replacing it soon, I cleaned the channels 3 times due to carbon cloging.



    http://www.caraudio.com/forums/signaturepics/sigpic14041_2.gif
    07 Jeep GC - Viper reps / afe stage 2 / chipped / h&r lowering springs

    Stock stereo

  14. #14
    LoudCrownVic's Avatar
    LoudCrownVic is offline 1/1 of Team Team Team



    Join Date
    Dec 2003
    Location
    Scales Bump, IL
    Age
    29
    Posts
    6,122
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    I demand T-Bird pics.



    I com to lern bout car awww-deeeee-ohhhhhs!
    Truck: 1998 Ford Ranger SC 2.5L 4 cyl 5 spd
    Mods- 195/60R15 Cooper Cobra Tires on stock rims
    System: HU- Eclipse CD8454, 2 Dayton RS180 7" midbass, Optimus 3" Horn Tweets hotglued to the dash, 3 12" JL W6v1's downfiring sealed, PPI PCX2200 @ 4 ohms, Alpine MRV-F545 mids and highs, 2 layers of Raamat on the doors.
    What's in Store:
    2 more Dayton RS180 7" midbass, 2 Bolender Grabender Neo planar tweets

  15. #15
    Silver's Avatar
    Silver is offline CarAudio.com Veteran

    Threadstarter


    Join Date
    May 2004
    Location
    Brighton, MI
    Age
    27
    Posts
    2,699
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: I need of a Car nut.

    Nothin special man, trust me. Here ya go though.









    SuperCoupe Rear Bumper on its way.

    Trans I put in it. (4r70w) Stang trans.




    http://www.caraudio.com/forums/signaturepics/sigpic14041_2.gif
    07 Jeep GC - Viper reps / afe stage 2 / chipped / h&r lowering springs

    Stock stereo

Closed Thread
Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may post attachments
  • You may edit your posts
1e2 Forum