Closed Thread
Results 1 to 2 of 2

Reload Thread: 2007 Camry sub/amp install

  1. #1
    Jimbanville's Avatar
    Jimbanville is offline Junior Member



    Join Date
    May 2012
    Location
    Ga. USA
    Posts
    1
    Post Thanks / Like
    Mentioned
    0 Post(s)

    2007 Camry sub/amp install

    Haven't touched a car stereo system beyond the volume knob in 20 yrs! Decided to add some bump to my Camry's already awesome factory-JBL stereo. Seriously, this stock stereo has surprised many ppl who hear it. I'm into 75/25 SQ vs SPL. Anyway...

    I used a scotch-lock connector (i know ppl don't like em, but they r good enough for me) to tap into the orange colored antenna power booster lead behind the radio for my amp turn-on signal. It gives 12v only when the radio is on. I ran the power wire through a rubber grommet above the gas pedal. I used a straightened coat hanger from inside to punch through to the engine bay. I then taped the power wire to the coat hanger and pulled the wire through. It's a VERY tight fit. No moisture can seep past the wire. I used scotch lock connector to tap into the rear deck woofer wires behind the passenger seat for my high level input into the amp. There are 4 sets of twisted pairs in the wiring harness : 2 for tweeters and 2 for woofers. 1 woofer is grn/wht(+) & brn(-). The other woofer is blu(+) & yel(-). The red mark on the white wires in my pics indicates +. There are holes in the horizontal brace behind the rear seat that I ran all the wires through. I'm gonna use a JBL GTO 1214 in a 1 cu ft sealed box and a Kenwood 8105D.







  2. #2
    hispls's Avatar
    hispls is offline CarAudio.com Veteran



    Join Date
    Sep 2009
    Location
    Cape Cod, Massachusetts
    Posts
    5,708
    Post Thanks / Like
    Images
    15
    Mentioned
    104 Post(s)

    Re: 2007 Camry sub/amp install

    A lot of ppl are happy just adding a small sub to factory system. Report back when you finish.




Closed Thread

Similar Threads

  1. Infiniti Q56 - Sub&Amp Install...Harness??
    By FASTIMES in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 12-27-2008, 04:10 PM
  2. sub/amp installation help
    By rodney05 in forum Wiring, Electrical and Installation Help
    Replies: 6
    Last Post: 09-14-2005, 12:35 PM
  3. First Sub/Amp Installed & Battery Died... HELP!
    By thugpassion in forum Wiring, Electrical and Installation Help
    Replies: 5
    Last Post: 10-21-2004, 09:30 PM
  4. Struggling with Xtant 301a sub amp install in 03 MDX
    By mlinarz in forum Wiring, Electrical and Installation Help
    Replies: 3
    Last Post: 07-24-2003, 12:26 AM
  5. tech difficulties with sub/amp install
    By acura cl in forum General Discussion
    Replies: 2
    Last Post: 08-09-2002, 02:09 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts

1e2 Forum