Closed Thread
Page 2 of 2 FirstFirst 1 2
Results 16 to 20 of 20

Reload Thread: Ford Ranger MT 15 build

  1. #16
    truckcap22's Avatar
    truckcap22 is offline CarAudio.com Elite



    Join Date
    Aug 2008
    Location
    petersburg, ky
    Posts
    786
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Ford Ranger MT 15 build

    i'm guessing you have the 95 amp alty which is usual for a ranger, if a 130 amp alty would work for what your running get one from a explorer







  2. #17
    DonH's Avatar
    DonH is offline .....



    Join Date
    Jun 2008
    Location
    So Cal
    Posts
    5,968
    Post Thanks / Like
    Mentioned
    36 Post(s)

    Re: Ford Ranger MT 15 build

    Quote Originally Posted by truckcap22 View Post
    i'm guessing you have the 95 amp alty which is usual for a ranger, if a 130 amp alty would work for what your running get one from a explorer
    my ranger has a 130 hehehe



    and what amp is powering the sub op?




    Quote Originally Posted by chillin View Post
    How do you bridge a mono?
    Quote Originally Posted by snoopdan View Post
    throw it off one.
    feedback thread:
    http://www.caraudio.com/forums/buyer-seller-feedback/402726-d-man1s-official-feedback-thread-2.html

  3. #18
    grassroots's Avatar
    grassroots is offline needs car audio rehab

    Threadstarter


    Join Date
    Nov 2006
    Location
    ATL
    Age
    26
    Posts
    1,206
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Ford Ranger MT 15 build

    autotek mm3000

    yes, it's a 90A. are the explorer alternators a direct bolt on? i've never looked into that before... my friends 97 expo just bit the dust and i might be able to rob it off his....



    refs: got em

  4. #19
    DonH's Avatar
    DonH is offline .....



    Join Date
    Jun 2008
    Location
    So Cal
    Posts
    5,968
    Post Thanks / Like
    Mentioned
    36 Post(s)

    Re: Ford Ranger MT 15 build

    Quote Originally Posted by grassroots View Post
    autotek mm3000

    yes, it's a 90A. are the explorer alternators a direct bolt on? i've never looked into that before... my friends 97 expo just bit the dust and i might be able to rob it off his....
    mine was just direct bolt up lol.... ive seen some that needed a little modding.




    Quote Originally Posted by chillin View Post
    How do you bridge a mono?
    Quote Originally Posted by snoopdan View Post
    throw it off one.
    feedback thread:
    http://www.caraudio.com/forums/buyer-seller-feedback/402726-d-man1s-official-feedback-thread-2.html

  5. #20
    truckcap22's Avatar
    truckcap22 is offline CarAudio.com Elite



    Join Date
    Aug 2008
    Location
    petersburg, ky
    Posts
    786
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Ford Ranger MT 15 build

    make sure its the 3g alternator unless you want to swap housings, i have a mechman high output from an explorer f/s if you want to swap the housing on it since its a 4g its like e3 r 4 bolts




Closed Thread
Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum