Closed Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 16

Reload Thread: Build Log: '99 Ford Explorer SQL Build

  1. #1
    funkycasey's Avatar
    funkycasey is offline Member



    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Build Log: '99 Ford Explorer SQL Build

    Well, I decided to get rid of the Kicker/Infinity system and upgrade big time....

    Going Zapco, CDT and Audiopulse for a SQL build.

    Got my Zapco Reference 1000.4 in as well as CDT CL-61A-25 PRO for my front stage. I will be using my Infinity Reference 5x7/6x8 for rear fill until I get a bit more cash to spend on some CDT Coaxials....

    As for the bass, I have a Zapco C2k 9.0XD coming in the mail which will be here within the next week hopefully. I ordered a custom made Audiopulse AXIS 15" and will be putting it into a sealed box that I build myself. Have yet to decide on box dimensions/volume, but plans will be in the near future.

    Since this equipment will be drawing a fairly big load, I am upgrading to a Excessive Amperage (Unless someone tells me otherwise) 300 Amp alternator, and will be upgrading my current back battery (Kinetic HC600) to a much larger battery.



    Anyway, today I got all of my new speaker wire run for the front components. Got the tweeters installed on the front pillars (I think they are called A pillars?). I did not decide to do fiberglassing for the tweeter pod because 1. I have no experience with glassing. 2. I will be selling my Explorer in the next year or less and don't want to change anything up TOO noticeably.

    Anyway, here are some pictures of what I've got so far....will be updating some more when I get the rest of my stuff in.

    PICTURES:











    OH, and yes I am going to clean up all of those wires....just wanted to show the current mess before I clean it all up, LOL
    Last edited by funkycasey; 10-14-2008 at 09:07 PM.







  2. #2
    funkycasey's Avatar
    funkycasey is offline Member

    Threadstarter


    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Got my Zapco C2K 9.0XD in today, and I am very happy with it. Just tested it out and it works perfectly. Got it off ebay for $860 shipped, and I can say that it is worth every penny. As most of you know, these amps retail for around $3,000 and can be gotten at Woofersetc.com for around $1,900 brand new.

    My 15" sub should be here within the next week or so hopefully.

    Anyway, seeing as i have a day off work, I am going to finish the front door component install and will see how it works out.

    Here are some pics of the 9.0:






    You can see that this amp has no Zapco sticker in the middle, which will make for a very clean looking install IMO....
    Last edited by funkycasey; 10-14-2008 at 09:08 PM.




  3. #3
    jdc753's Avatar
    jdc753 is offline Truck Brigade



    Join Date
    Nov 2006
    Location
    Mass
    Age
    29
    Posts
    1,891
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    dang looking like some good equipment. Hope you can get it all installed nicely. Looking forward to seeing your progress.

    One thing I will say see if you can post the pics into the thread. Clicking links ****.



    2005 F350 crew cab diesel 4x4
    -Work in Progress-
    HU: Alpine 9887 linked to 10.4" TS TruckPC
    Front Stage: Polk SR6500 Active
    Front Amp: Sundown Sax100.4
    Sub: Stereo Integrity Magnum V4 in the center console
    Sub amp: Sundown Saz-1500D

    Refs: low_end, Relax, SSon22s, Johnson, tyroneshoes, twisztdpunisher, flakko, djhn9, KINGDELL91, amoffitt, Justin89T, 01 S 10, Mazzasec

  4. #4
    funkycasey's Avatar
    funkycasey is offline Member

    Threadstarter


    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Well, I got the component set completely installed today (about time). Hooked them up to my Zapco Reference 1000.4 and everything sounds great. It got too dark before I had time to put the door panels back on, so I am not sure if they are going to fit back right, but I will find out Thursday when I get another day off work.








  5. #5
    funkycasey's Avatar
    funkycasey is offline Member

    Threadstarter


    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Quote Originally Posted by jdc753 View Post
    One thing I will say see if you can post the pics into the thread. Clicking links ****.
    Thanks for telling me that....I never really knew how to do that until just now, lol




  6. #6
    jdc753's Avatar
    jdc753 is offline Truck Brigade



    Join Date
    Nov 2006
    Location
    Mass
    Age
    29
    Posts
    1,891
    Post Thanks / Like
    Images
    2
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Quote Originally Posted by funkycasey View Post
    Thanks for telling me that....I never really knew how to do that until just now, lol
    no prob glad to help. Everything is looking pretty good so far. Hope it all sounds as good as it looks.



    2005 F350 crew cab diesel 4x4
    -Work in Progress-
    HU: Alpine 9887 linked to 10.4" TS TruckPC
    Front Stage: Polk SR6500 Active
    Front Amp: Sundown Sax100.4
    Sub: Stereo Integrity Magnum V4 in the center console
    Sub amp: Sundown Saz-1500D

    Refs: low_end, Relax, SSon22s, Johnson, tyroneshoes, twisztdpunisher, flakko, djhn9, KINGDELL91, amoffitt, Justin89T, 01 S 10, Mazzasec

  7. #7
    funkycasey's Avatar
    funkycasey is offline Member

    Threadstarter


    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Yea, the mdf cutouts look fairly rigged up, but it's all about the sound...and nobody will see the rough cutouts when i put the door panel back on (if it fits back the way it is supposed to at least).

    I'll post some more progress once I get the subwoofer in.




  8. #8
    Wkbdkid's Avatar
    Wkbdkid is offline CarAudio.com Veteran



    Join Date
    Mar 2006
    Location
    San Diego
    Posts
    2,834
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Everything is looking good. Baffles look a bit long an wide, might run into some problems there. I made a 6.5x8.5 baffle for mine an it barely clears it.G/L though



    Refs: ToxicTuan, LivinLife, BigWill, Bushtree,Chaarlieee,80INCHES, SupaC,Rtillaree,Dalucifer, Dumple91, CRXBMPN, Shallowfu, Calikid, 90accordman, Zeuslicious, IonSQL, Quino, Slowbmw,Twisztdpunisher,
    themommyvan, MSW Danny, Theelfkeeper, Fusion FREAK, Bigtymer2306, keviNxL, WooferCooker, Team H & K, Luv2Shroom

  9. #9
    funkycasey's Avatar
    funkycasey is offline Member

    Threadstarter


    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Yea mine is 7.5 x 8 with that one side sawed off....hope it works, LOL. I would hate to take it back off, but i guess that's the fun of car audio!

    I'm pretty sure it will work though, because if i am not mistaken, the rough side nearest the inside of the door where the dynomat is sort of torn and you can see the black tar is where the door panel ends.




  10. #10
    46panel's Avatar
    46panel is offline CarAudio.com Elite



    Join Date
    Apr 2008
    Location
    Michigan
    Posts
    1,188
    Post Thanks / Like
    Mentioned
    1 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    This is exactly what I was looking for, I got a 99 explorer and want to put the PG RSD components in there, did your baffle allow yours to work?




  11. #11
    funkycasey's Avatar
    funkycasey is offline Member

    Threadstarter


    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Quote Originally Posted by 46panel View Post
    This is exactly what I was looking for, I got a 99 explorer and want to put the PG RSD components in there, did your baffle allow yours to work?
    Sure did. Baffle is only 1/2" MDF. Now, i've still been too lazy to put the door panels back on, so not sure about that yet, but I should be able to get some time Tuesday to put them on.

    In other news, the robot underground guy that I am getting my 15" Audiopulse Axis (TC 3000) from emailed me a few days ago and said that since they were taking longer than expected to do my custom picture on the dust cap, they would upgrade my subwoofer to the Neo motor....which is gonna be a nice upgrade

    Anyway, I'll see how the door panel fits and update on tuesday hopefully.




  12. #12
    audioqueboy's Avatar
    audioqueboy is offline ICE-MIKE



    Join Date
    Nov 2006
    Location
    Illinois the city
    Posts
    618
    Post Thanks / Like
    Images
    16
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    looking good i have to do the same baffle work for my comps set im using polk db 6.5



    HU Clarion
    front comps- polk audio 6 1/2
    rear speaker - pioneer 6x8
    High amp Coming soon
    Mechman Alt 200 amp
    Big 3 0 guage
    2 Digital Design 9515s subwoofer
    2 Audioque 2200 amp
    Box 8.5 cuft 38hz 148.1 TL music
    Temp system 1 -15 dd on 4k 146.4 TL music
    Amp and Battery rack
    Ice-Mike Customs [/FONT]

    REFER: woofercooker, jbizzle,, big joker, lil italy773,wu501

  13. #13
    funkycasey's Avatar
    funkycasey is offline Member

    Threadstarter


    Join Date
    Sep 2008
    Location
    Arkansas
    Posts
    131
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    Well, I finally got everything in the mail and had time to hook everything up....I decided to buy a Zapco C2K 4.0 as my 4 channel amp so that the amps would match (9.0 and 4.0). I found a crappy little sealed box for a 15" in a garage sale and decided to buy it since i completely **** at making boxes myself. Box is about 2.0 cubic feet which is a little on the small side for this sub, but so far it sounds good. I am slowly breaking it in at this point, and everything is looking good.

    Oh, and i decided to buy a 250amp Mechman amp for those that are wondering. Here's some pics:











  14. #14
    splferrell's Avatar
    splferrell is offline Member



    Join Date
    Aug 2008
    Location
    Toledo, Ohio, United States
    Posts
    90
    Post Thanks / Like
    Mentioned
    0 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    that sub look bad ***, nice pics




  15. #15
    Random1010's Avatar
    Random1010 is offline CarAudio.com Veteran



    Join Date
    Feb 2005
    Location
    Yes
    Posts
    7,479
    Post Thanks / Like
    Mentioned
    2 Post(s)

    Re: Build Log: '99 Ford Explorer SQL Build

    I just put the same comps in my 00 explorer..except I used 3/4 mdf.




Closed Thread
Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum