Closed Thread
Results 1 to 3 of 3

Reload Thread: emblem fell off my amp today

  1. #1
    Mr.meyhem's Avatar
    Mr.meyhem is offline CarAudio.com Elite



    Join Date
    Nov 2011
    Location
    Cold as F***, MN
    Posts
    1,056
    Post Thanks / Like
    Images
    15
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    160 Post(s)

    emblem fell off my amp today

    The emblem off my cadence xa 250.2 and I wanted to put it back on. It looked like their was just one touch of glue or something behind it. Can I just use super glue? Or would that be hard on the amp? Because there are 3 holes under the emblem where it slides in and I don't want to accidentally get glue on the guts. Any suggestions? I bought the amp from sonic less than a year ago.



    Obsidian 15 D2 3.5 cubes 31hrtz
    Apsm 1300
    Alpine Type R 6.5 comps
    Cadence 250.2
    KnuKonceptz Kollossus Flex 4 awg
    AP LOC
    Distro Block
    2/0 Big 3
    ELD bypass in progress




  2. #2
    Serpent710's Avatar
    Serpent710 is offline CarAudio.com Veteran



    Join Date
    Feb 2008
    Location
    Florida
    Posts
    2,652
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    564 Post(s)

    Re: emblem fell off my amp today

    dont see a problem with a few small drops of super glue. usually dries very thin, and you dont need a lot. just put it in places with no chance of hitting the guts



    Refs: mike11202, Tehgregzor, Twisted_0912, Goindef154, fasfocus00, got_focus?, Boswell59, 2lows10, skateguy92, Worstenemy453, Supergumby5000, gboo559, ryanm923, GetLikeMe, TaylorFade, Dacheatham, pickup1, jerseyboy, TWiZTiD859, Kangaroux, 09civic

    Sub: 2 12" Cerwin Vega Vmax
    Comps: Boston
    Enclosure: Birch Bitch
    Amp: JBL Crown BPx1100.1
    H/U: Pioneer Premier FH-p800bt
    Wiring: Stinger HPM

  3. Likes CADENCE SOUND liked this post
  4. #3
    CADENCE SOUND's Avatar
    CADENCE SOUND is offline Senior VIP Member



    Join Date
    Jul 2011
    Location
    Howell, New Jersey, United States
    Posts
    470
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quoted
    75 Post(s)

    Re: emblem fell off my amp today

    Badges falling off is not very common, but these things happen. Id put a light film of some gorilla glue and just let it sit over night..

    No need to take the amp out or anything, Just try to avoid using the amp while the glue is still tacky, the heat might interrupt the drying process.




Closed Thread

Similar Threads

  1. Remote Wire Not Turning Off My Amp
    By xautobotx in forum Amplifiers
    Replies: 16
    Last Post: 10-14-2005, 11:32 PM
  2. resetting the gains on my amps today...
    By flakko in forum Wiring, Electrical and Installation Help
    Replies: 1
    Last Post: 05-12-2005, 03:41 AM
  3. The magnets fell off my RE SE 15!
    By ChuteBoxe515 in forum Subwoofers
    Replies: 87
    Last Post: 11-01-2004, 01:05 AM
  4. Turning off my Amp via switch on the remote
    By bobhope in forum Wiring, Electrical and Installation Help
    Replies: 9
    Last Post: 07-26-2003, 04:45 AM
  5. static off my amp
    By Unregistered in forum Amplifiers
    Replies: 1
    Last Post: 02-23-2002, 05:56 PM

User Tag List

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may edit your posts
1e2 Forum