PDA

View Full Version : car overheating??



.::DuD3::.
05-04-2005, 05:54 PM
my car (96 camaro rs) is overheating now, after i just bought it a month ago. car was supposedly in great condition, only 75k miles. but anyways, i think i've narrowed it down to a few things. i changed the thermostat yesterday, so thats not the problem. i'm wondering if maybe my cooling fans are not working, and i checked the radiator, and it should be flushed. but do you think the radiator is whats causing this problem? also it overheats only in traffic, when i speed up, it cools down (which is why i think its the cooling fans). any ideas? i dont wanna take it to some shop and pay $80 for a diagnostic. thanks in advance.

Polecat
05-04-2005, 06:42 PM
if it only heats up while at idle, like in traffic, it's an airflow problem. I would check the water to make sure there's a 50/50 mix, and be sure the fans come on. Start the car, and have someone watch the temp while you watch the fans. If they don't come on, you know your culprit. If they do, then the radiator will need to be professionally flushed. These cars are common with pool ventilation up front.

.::DuD3::.
05-04-2005, 07:34 PM
yeah, at idle the water temp goes well past the center marker of the gauge, and the fans dont come on. i checked the fuse box, and the relays seem fine. i hope the fans aren't shot :( .
(sorry for double post)

Polecat
05-04-2005, 07:36 PM
if they are, check salvage yards first... :)

.::DuD3::.
05-04-2005, 08:13 PM
****, how much you think thatll run me ? :rolleyes:

Polecat
05-04-2005, 08:17 PM
about $20-$30

.::DuD3::.
05-04-2005, 08:49 PM
oh ok sweet :D guess that means no taco bell for a week ;). thanks for the help.

Polecat
05-05-2005, 09:07 AM
oh ok sweet :D guess that means no taco bell for a week ;). thanks for the help.
anytime my man. Good luck! :)

pablo4429
05-15-2005, 07:05 PM
make sure you replaced the thermostat with the exact OEM original or it can overheat very easily.

datguyclark
05-19-2005, 04:20 PM
^^if if overheats in trafic and cools when driving...like polecat said..must be airflow and most likely fans, fan clutch yada yada

Dustin19
05-23-2005, 09:46 AM
Check your um water pump too. Or WHATEVER it is called.