PDA

View Full Version : Kenwood KDC-X789



eberrong
03-23-2005, 03:06 AM
I just got a Kenwood KDC-X789 which is one of the higher end models. I've got to say that I am not all that impressed with the sound quality. I replaced the stock headunit in my 99 civic si and I am starting to wonder if the stock unit sounded better?? Is that possible? I have the stock 6 speaker setup and have been out of the car audio loop for about 6 years.

I went with the Kenwood because of the features. It has tons of great features...3 line text display, Sirius Ready (I got the Sirius tuner with it), HD Radio ready, mp3, wma, aac, 3 sets of 5V RCAs, 24 bit Burr Brown DAC, Music Keg ready, RDS. etc. No other manufacturer really had a comparable model when you consider all of the great features.

Back 6 years ago Kenwood was a pretty respectable head unit. Has Kenwood's SQ gone to crap? Are the other's any better?

Decipha
03-23-2005, 04:08 AM
just out of curiousity - wut manufacturer made the stock radio?



"I am starting to wonder if the stock unit sounded better?? Is that possible?"
-if the two most important people r named **** and Bush... anythings possible!

Decipha
03-23-2005, 04:09 AM
From what i've heard (i hear alot) the two best head units you can get that are proven not to skip are Pioneer and Alpine... as far as sound quality i couldn't tell ya but every car audio place i go to tells me the same answer

eberrong
03-23-2005, 08:00 AM
Not sure who made this 1999 Honda HU. For some reason...alpine sticks in my mind. Maybe someone else will know.

About 6 years ago I thought any aftermarket HU was better than any stock HU. I guess things have changed. I imagine that some of the stock units have gotten better (my wife's brand new CR-V stock stereo sounds great!) and some of the aftermarket units have gotten worse?

Dozerboy
03-23-2005, 09:22 PM
Mine sounds good SQ wise but the FM reception ***** I think the service department messed it up. I will never buy another Kenwood.

eberrong
03-25-2005, 10:09 PM
Well I proved it to myself today by putting my OEM stereo back in my car. The OEM head unit sounds much better than the X789. The X789 is getting returned...it was just way to harsh in the midrange for me. No amount of EQ tweaking could help it either.

golfreak
03-27-2005, 07:01 AM
You got to be joking man.
I have the same car Civic Si and I know excatly what you have.
The head unit is a piece of *****.
Its power has to be 10w rms MAX.
When I replaced it with a cheapo Pana CQ-1300(Pana lowest MP3 HU), I could tell the sound was better.

And it is such a coincident that I just happenned to buy a Kenwood 789 myself.
It won't get here till Tues so I'll give you my review then.

But seriously, if you don't have an amp hooked up, no matter what HU you'
re going to buy will make those factory speakers sound any better.
Still, I can't believe that you think the OEM HU sounds better.
Are you sure its hooked up right ??

BTW, its another coincident that I live in Orlando too.
Although not right now. I'm in Cali for the moment.

Heres a picture of the OEM HU.

http://home.cfl.rr.com/golfreak/cd2.jpg

itstodd
03-27-2005, 05:39 PM
Hmm...my Kenwood KDC-X579 (two models down, and last year's) sounds phenomenal!

golfreak
03-27-2005, 07:10 PM
Hmm...my Kenwood KDC-X579 (two models down, and last year's) sounds phenomenal!

I've been reading good things about the Excelon line.
I was going to buy the 589(this yr equivalent to the 579) for $160 but I decided to spring $50 more for the 789 model.
The difference is the 789 has 5v(vs 4v), a aux input and color display.

I chose an Excelon because I heard how good the SQ was because of the 24-bit proccesor and its freakin cheaper than comparable models.

BTW....how much did you pay for the 789 ???
Where at ?? I thought you can 't return HU once its installed.

golfreak
03-29-2005, 10:48 PM
Well, I got mine today and hooked it up.
To sum it up, the sound is amazing.
It sounds like I have different AMPs in my car...crisp and clear and thumping.
Theres an option to turn off the internal amp and it sounded better than it did before.

I don't know what happenned to yours...maybe its hooked up wrong or something but you can't be talking baout the same HU as I have.

Gorgeous all around....worth every bit the $210 I spent on Ebay.

eberrong
04-02-2005, 11:05 PM
I do not have separate amps (yet) in my car so maybe that is the difference. But I can say with confidence that the Kenwood HU's midrange was killing my ears, very harsh. I listen to a lot of music with distorted guitars and they just didn't sound right.

I guess it was a bit louder (more powerful) than the stock HU, but that was a moot point since it sounded like crap.

I will likely try an Alpine unit. They seem to get rave reviews for sound quality...while Kenwood gets mixed reviews at best.

Spr0ket
04-07-2005, 01:20 AM
If you get an Alpine, make sure you stay away from the CDE line or the CDA line sold at the local Best Buy. The quality of those units are not up to par of the previous years Alpines (9833 etc). I've got a KDC-X789 in one car no amps, and a KDC-X889 in the other with JL amps. Both units are absolutely fantastic once a good speaker staging is set up and the sound managment system is set. The 889 offers loads of DSP features such as delayed timing, SRS Wow effects, cabin location positioning, and tons more. The 889 is one of the best HUs I've owned. The 789 is not far behind in sound quality. The 789 hooked up without amps and good speakers (JL TR650CSi front, Clarion ProAudio 6x9s rear) sounds **** good for not having any amps. The last HU I had in my car with the exact same speaker setup was the Alpine CDA-9833, I like my Kenwood better as the navigation is more intuitive and has more DSP effects to shape the audio to fit my needs.

marley1
04-07-2005, 02:04 PM
you say six speaker. which could be the major reason. i bet it some weird ohm load or their was osme wierd processing on teh stock unit.

so when you replaced it it screwed it all up.

i ordered a 789 myself, 185 + 20 shipping then i picked up a warranty for 14 for 3 years it was like 230 shipped all said and done. Cant wait for it will be replacing a odler 8 series excelon :)

golfreak
04-08-2005, 03:58 AM
you say six speaker. which could be the major reason. i bet it some weird ohm load or their was osme wierd processing on teh stock unit.

so when you replaced it it screwed it all up.

i ordered a 789 myself, 185 + 20 shipping then i picked up a warranty for 14 for 3 years it was like 230 shipped all said and done. Cant wait for it will be replacing a odler 8 series excelon :)

No its not that. It must have been installed wrong or something.
I have the same exact car and the exact HU so I know.

The speakers up front is like a coaxial......all it really is is that they place the tweeters in a seperate location.
So its a 2-way 6x9 in the back and a 6.5 in the front. Instead of the tweeters sitting in the middle of the 6.5 cones, it sits in a seperate spot.
And the factory HU is a POS. I don't see how he thinks it sounds better.

VOA_NIGHTMARE
04-08-2005, 04:10 AM
Sounds like the eq settings could be off. I had a kenwood and it sounded like sht until it got tweaked right, now I can honestly say it was one of the BEST hu's I have ever ran. And I dont run junk ones. Right now I am running a pioneer 860mp. And I think the sq on the kenwood I had was better.

golfreak
04-08-2005, 04:13 AM
you say six speaker. which could be the major reason. i bet it some weird ohm load or their was osme wierd processing on teh stock unit.

so when you replaced it it screwed it all up.

i ordered a 789 myself, 185 + 20 shipping then i picked up a warranty for 14 for 3 years it was like 230 shipped all said and done. Cant wait for it will be replacing a odler 8 series excelon :)


BTW, wher did you find the 789 for $215 shipped ??
I've been looking on Ebay for a weeks and the lowest I've seen is $210 shipped and I bought one.

newb
04-12-2005, 07:55 AM
Sorry to say but I have the model right under yours in my crx and the sound quality isnt all that great either. Same with my 9835. I think older HU's sound way better with the basic treble and bass settings. Because of this Im in the market for a 1/2 din eq to fine tune it more.

VOA_NIGHTMARE
04-12-2005, 09:59 AM
Sorry to say but I have the model right under yours in my crx and the sound quality isnt all that great either. Same with my 9835. I think older HU's sound way better with the basic treble and bass settings. Because of this Im in the market for a 1/2 din eq to fine tune it more.

Sounds like you dont know how to really set them up correctly

EvOLuTNMotORs
04-12-2005, 11:08 AM
i had a Kenwood unit in my car. i would never recomend them again to any one doin high end systems, there are good units for everyday driving (prices). but not for a serious setup. i just got a Alpine CDA-9833 and there is a HUGE difference in SQ. if your on a budget kenwood is fine!!!!

MDDrew
04-12-2005, 12:04 PM
yet alpines snr is lower than sonys

VOA_NIGHTMARE
04-12-2005, 03:07 PM
alot will depend on the kenwoods. I have heard the newer line is not too good. But I have ran some of the older ones like the x711 and the x911. And those were some killer hu's I just sold my x711 after using it for like 4 yrs. And it still to this day is one of the best units I have ever ran.

EvOLuTNMotORs
04-13-2005, 04:20 AM
i think it's just a matter of preference. i had what alot of people thought was a killer setup. but from my point of view it wasn't what i was looking to get out of it. it wasn't bad but i felt it could sound alot better

newb
04-13-2005, 11:16 PM
Sounds like you dont know how to really set them up correctly


mind giving me some pointers...?? Ive tried all I can.

VOA_NIGHTMARE
04-14-2005, 02:01 AM
I will need to look up that deck and see what features it has on it, but the x711 had a bunch that was nice with it, all crossovers on each thing etc.

Sound Gorillaz
07-18-2005, 03:47 PM
I have an x789 and I think it is a killer hu. I jsut replaced my Rockford deck and I am happy. It is all a matter of tuning it right.

You also have to realize a stock hu is setup to run on those stock speakers. Your new one no matter what you buy will have to be played with to get it to sound right with the stock units.