PDA

View Full Version : setting crossover settings



noob with an RS
01-26-2005, 10:40 PM
hey i have a set of infinity perfect 6.1 components and i am using a Hifonics nx600 to power it (150 watts x2). should i set the crossover on my alpine to OFF and use the crossover on the hifonics? i'm thinking about doing this because the lowest crossover point the deck can do is 80 hZ.. and my perfects frequency response starts at 75 hZ.. so basically i was thinking turn the x-over on the HU off and use the amp to fine-tune it. or would it just be a lot better to have my great Alpine 7995 to crossover the highs at 80 hZ?? if i use the head unit to do the crossing over then i should and could set the crossover to FULL right? any feedback will be greatly appreciated. thanks.

desertheat
01-26-2005, 10:41 PM
Why would you post this in 3 different area's of this forum.. sheesh

noob with an RS
01-26-2005, 10:45 PM
hahahahha sorry.. you caught me. :( i just thought I'd get a lot more "second opinions." plus, i thought i could get away with it being my question involves three different components. will i get in trouble with the moderators???

theCybe
01-26-2005, 11:10 PM
No crossover with your component set?

I was told you want your signal full right up until the last piece of the puzzle; I'm not familiar with your headunit, but I know my pass filters apply to both the front AND rear speakers - which I'd naturally want to have seperate settings.

Unfortunately, they're not amped, and have no crossover available aside from the headunit.