PDA

View Full Version : I need help from u guys again!



123456789
01-24-2005, 11:18 PM
O.k, after getting ripped off last year & having you guys help me out, I finally got the wiring & box situation worked out. Subzone box, 12" vegas presicion power dcx amp 500.2. The problem that im having now, my subs are bridged & my amp keeps shutting off. Took it to my local car audio & he said with my subs bridged,the Ohm load from my subs & amp are wrong or something. He tried to get me to trade him My PPI amp for a 200.00 logic amp that would be compatible with my vega subs. I learned from the last time i got my head knocked off, i dont do anything with my car system until i check it out with you guys first. When I wouldnt trade, he tried to sell me some jl audio w/o's & W/3's that would be compatible with my AMP. im a girl, & unfortunatly, there are some ***** out here that try to SCREW me. (hehe) So what do you guys recommend? I like my amp so I would like to go the swapping sub route. here are the specs on my amp ....... Oh yea, the guy said my amp isnt that good, that it is more compatible for DOOR SPEAKERS NOT SUBS. Well PLEASE GIVE ME SOME SUGGESTIONS! [email protected]
4 ohm: 125x2
2 ohm: 250x2
Mono Operation: 500Wx1 @ 4 ohm
THD+N: 0.08%
S/N Ratio: >100dB
Freq. Resp.: 10Hz-50kHz
Damping Factor: >300
X/O Slope: 2-way, 30Hz-4kHz, 12dB/octave
Fan: Yes
QBass™: QBASS Plus/Remote
Dimensions: 16-1/8"x10-1/2"x2-3/4"

squeak9798
01-24-2005, 11:21 PM
PPI are pretty nice amps.....I'd keep the amp. I don't know anything about your sub (12" Vegas?), but the JL W3's are pretty decent. Good quality subs.

jtomsic
01-24-2005, 11:24 PM
swap the sub not the amp.

Dj-torn
01-25-2005, 12:18 AM
How many Subs do you have and what is the ohm resistance on them? Depending on how you have bridged your subs you might be putting too much strain on the amp. Take a look at this link;

http://forums.caraudio.com/vb/showthread.php?t=31984

If that is ok, then there are only two other posibilities, either your amp is not breathing properly and its overheating and shutting off as a safety mechanism or the wireing to the amp is faulty.