PDA

View Full Version : check engine light came on....



graffix989
01-24-2005, 10:31 AM
ok just hooked up my system friday, lanzar VIBE286 amp(2000wattz). by sunday i noticed the check engine light came on in my car... ok so my question is that if my amp is drawing too much power will it make the check engine light go off?? shouldnt it make the little batt light turn on instead? or is this just a quencidence. i noticed my bat seems to be getting a little weaker when i go to start up my car too, but its done that ever scense this whole single digits cold front pushed in... i dunno i could be a combo of dif things my car is a POS. but i wanted to know if anyone elses light came on shortly after installing their system.

also i dont realy crank my system up all the time eithor, i dont even have it making any kind of noise when im in the neighbor hood cuz my car will get broken into. so for now instead of upgrading to the HO alt. could i just use a switch to controll the power to my amp instead of the HU, so i could keep it turned off so the batt has enough time to recharge after running it so hard... or would that just be wasted effort.

ExS
01-24-2005, 10:41 AM
I had the same problem before when after I installed head unit. The light was on, but after couple of months it was off again.

n2audio
01-24-2005, 12:29 PM
could i just use a switch to controll the power to my amp instead of the HU, so i could keep it turned off so the batt has enough time to recharge after running it so hard... or would that just be wasted effort.
Just turn the volume down (near minimum) a couple minutes before you turn the enginge off. That should help you get a little extra charge to the battery.

With your check engine light -- What are you driving, and exactly how many miles are on it?

graffix989
01-24-2005, 02:42 PM
its a 92 cavalier, 133k
nothin was wrong wit it before i put the system in it... then a day or two later it came on.. i was just wonderin if my install could of made the light come on, ill find out what the error code is tommarow. just wanted to see if anyone else had this problem before so i dont sound like an *** when im talkin to the mechanic

deadboi77
01-24-2005, 03:28 PM
The light was on, but after couple of months it was off again.
im not sure bout your ride but im mine(`96 cherokee)it resets itself after 50 start ups..krazy thing is last sunday(when a on a good road trip to a car show)and on the way home my GEN lite came on but i was getting norm volts(13.5-14.2) to my amp but we stopped and ate.. started it back up and it was off

Vestax
01-24-2005, 04:32 PM
Check engine light can mean a number of things. It varies on every car. You can take it to a shop that can diagnose the problem and they'll tell you what it is. Normally, if you disconnected the battery while the key was still in ignition, the check engine light will go on. Try disconnecting the battery for a bit, then plug it back in and see if it'll go off.

Bigrick31
01-24-2005, 04:36 PM
unhook your battery for a few minutes then hook it back up. should reset everything. somethims it makes the light go off meaning that there was no real problem with your car.

j3bus2k3
01-26-2005, 02:50 PM
If you don't have a seperate oil light, then its just a reminder to get your oil changed or your due for maintence according to the manufacturer. Sometimes they're just money making schemes but more often then not, they actually serve a purpose.

DBfan187
01-26-2005, 08:46 PM
A lot of times it means that your O2 sensor is bad. Take it to a shop, get a back pressure test done on the catalytic convertor before the diagnostic test.

BigPimpin18
01-27-2005, 05:20 PM
juss use an OBD2 sensor on it. Also check if your alternator is good (while your car is running disconnect the positive battery terminal) I had this happen to my car this past week. Also check your grounds with an ohm meter, and if you have 0 ohms than it's a good ground if not than you wanna change your ground.

dbhittin
01-27-2005, 05:33 PM
or u can turn your key to the on postion, find your ecu, turn the dial, and check for codes to see why its on.. then go from there

zane
01-27-2005, 05:56 PM
juss use an OBD2 sensor on it. Also check if your alternator is good (while your car is running disconnect the positive battery terminal) I had this happen to my car this past week. Also check your grounds with an ohm meter, and if you have 0 ohms than it's a good ground if not than you wanna change your ground.


OBDII was not present until late 1994, this car is still OBDI.

There are several relatively in-expensive OBDI Code Readers available at most local auto stores and even some Wal-Mart's.

The OBDI ports were typically under the hood on most models, but a few did locate them under the dash, glovebox, or behind the kick panels.

OBDI Code Readers typically use a small LED to flash the code from the vehicle. You simply observe the number of flashes of the LED and their sequence, and refer to the included book, or a Chiltons Manual for your vehicle, to see which code is being thrown.


That's your first and most important step.

I would seriously advise not doing anything else until you know what caused the MIL to come on.

Ignoring it will in most situations cause the vehicle to go into "Limp Home Mode" where it's bare basics are all that's used engine wise. Performance, efficiency, fuel economy, etc, all suffer greatly in this situation.

Throwing parts at it without the OBDI information is just a plain idiots way of working, and costs quite a bit more, and seldom works.


Bottom line - get the code(s) first, or have AutoZone, or a Mechanic do so.

Then and only then will you know the next (second) step to take.

Scan the codes on the vehicle before anything is done.

`pr0digy
01-28-2005, 06:36 PM
OBDII was not present until late 1994, this car is still OBDI.

There are several relatively in-expensive OBDI Code Readers available at most local auto stores and even some Wal-Mart's.

The OBDI ports were typically under the hood on most models, but a few did locate them under the dash, glovebox, or behind the kick panels.

OBDI Code Readers typically use a small LED to flash the code from the vehicle. You simply observe the number of flashes of the LED and their sequence, and refer to the included book, or a Chiltons Manual for your vehicle, to see which code is being thrown.


That's your first and most important step.

I would seriously advise not doing anything else until you know what caused the MIL to come on.

Ignoring it will in most situations cause the vehicle to go into "Limp Home Mode" where it's bare basics are all that's used engine wise. Performance, efficiency, fuel economy, etc, all suffer greatly in this situation.

Throwing parts at it without the OBDI information is just a plain idiots way of working, and costs quite a bit more, and seldom works.


Bottom line - get the code(s) first, or have AutoZone, or a Mechanic do so.

Then and only then will you know the next (second) step to take.

Scan the codes on the vehicle before anything is done.


I agree.... My car has a built in OBDI connector w/ probe, makes that pesky light SO much easier to deal with :)

Primo
01-28-2005, 08:18 PM
on my truck it's easy to turn off. two wires under the dash, one of them is connected and the other isn't, just switch them and problem solved. it went off at 80k and 120k miles.

ighettoboyi
02-06-2005, 01:57 PM
autozone lets you use their scanner for free....that's what i do