PDA

View Full Version : component question...



cjj2d
01-16-2005, 01:10 AM
what are some reasons why a tweeter of a comp set would be going in and out. I just rand brand new speaker wires all the way from amp to speakers and all. The speakers are brand new.

Only one is doing it. Could it be the RCAs??

Slody4Futbol
01-16-2005, 01:20 AM
if it was rca... then the mid & tweeter would go out... because that's on the same channel... it's probably the tweeter protection circuit coming on to protect the tweeter...

desi_daru
01-16-2005, 05:57 AM
if it was rca... then the mid & tweeter would go out... because that's on the same channel... it's probably the tweeter protection circuit coming on to protect the tweeter...


couldnt have put it better

cjj2d
01-16-2005, 09:22 AM
what would make it go in to protect?? the amp not sending a good signal? it does it at random volume levels.

Slody4Futbol
01-16-2005, 12:55 PM
gains set to high... eq set to high on the treble... any sort of boost on your tweeter frequencies... does your crossover have a tweeter attenuation on it? use it

cjj2d
01-16-2005, 03:46 PM
yeah, I will try and set the tweeter to -2db and see if that helps. also my HU settings are not in line. I have not tweaked it out yet.

cjj2d
01-17-2005, 01:36 PM
well I have narrowed my problem down. It has to be the tweeter itself. since my crossovers are now in the trunk its easy to access them. So I swapped the tweeters to the opposite crossovers to test and see if it was the crossover. Well it did the same thing on the opposite crossover. So now I think I have a screwed up tweeter. Now to just find out where to get another one. I am going to call the DA dealer here in Nashville and see how much it would be.