PDA

View Full Version : right 6x9 making rattling noise.. may need replacing help me find replacement



Tater_Salad
11-19-2004, 10:34 PM
i have a pair of pioneer premier 6x9 full ranges they sounded awsome in my little car until I think i might have fried my right one it makes a rattling noise like its got a quarter stuck in it or something can it be repaird?
if not what speakers should i replace the with? i was thinking maybe infinity kappa 693.5I or Pioneer TS-A6990R if i can find a good price

bonesninja
11-19-2004, 11:00 PM
do you have subs in your trunk? i ended up blowing the cone on one of my rear deck speakers from the bass in my trunk making the cone excurd too far. the solution is some cheap baffles from local shop or at crutchfield etc.

Sleeklsc
11-20-2004, 02:22 AM
i have a pair of pioneer premier 6x9 full ranges they sounded awsome in my little car until I think i might have fried my right one it makes a rattling noise like its got a quarter stuck in it or something can it be repaird?
if not what speakers should i replace the with? i was thinking maybe infinity kappa 693.5I or Pioneer TS-A6990R if i can find a good price


turn it down!

anywho, they would not be worth gettin fixed...go to www.ikesound.com for some great deals on speaks...ebay prices but not ebay...

what do you have in front and are you amping them? if so what are you using?

p.s. check to see if a screw or sumtin came undone causeing that noise..

Tater_Salad
11-20-2004, 08:48 AM
no sub... but planning on one 12"
im only running these 2 for now since im broke but they sounded way good since my car is so small (84 vw rabbit pics soon)
baffles?

bonesninja
11-20-2004, 08:59 PM
no sub... but planning on one 12"
im only running these 2 for now since im broke but they sounded way good since my car is so small (84 vw rabbit pics soon)
baffles?

yeah baffles--they these cheap *** little foam things that you put over the trunk side of the speakers to keep the air pressure from subwoofers from pushing on the cones of your 6x9

Tater_Salad
11-21-2004, 05:57 PM
i fixed it...

Sleeklsc
11-21-2004, 06:08 PM
glad to hear it!

what was the prob?

Tater_Salad
11-21-2004, 07:38 PM
not sure really... but there was a drop of soder on the woofer cone that I scraped off prolly caused some imbalance and i tightend the magnet on the bottom

MValley70
11-22-2004, 12:03 AM
Well that good that you fixed it...but i was going to say i had some JBL T595 Limited 6x9's for sale if you wanted them

HERE (http://www.cardomain.com/item/JBLT595) is a link to them

Scott, SC