View Full Version : Headunit cutting out....

11-04-2004, 10:09 PM
Today, about 2 mintues into my commute, my head unit cut out. Only my rcas were working cause my subs were working fine. None of my door speakers running off the HU were working. After school, i turn on my truck, same thing....then, all of a sudden, they start working again. Then they cut out. Then they started working again.....its a kenwood MP-425. This is my first problem with it....got any suggestions?

11-04-2004, 10:39 PM
mine is doing the same thing except that everything turns off for a sec

11-05-2004, 01:57 AM
Mines off for several minutes at a time

11-05-2004, 02:13 AM
bad speaker... loose wire... wire or terminal grounding out...

11-05-2004, 03:23 AM
but all 4 speakers cut out....thats what puzzles me....all 4 door speakers just suddenly stop....and my subs still work

11-05-2004, 10:52 AM
Yes because your HU is pushing an internal amp and the RCA'S do not go through that HU amp. Thus if there is a loose wire in your front speakers it is grounding out the amplified portion of your HU.

11-05-2004, 11:00 AM
yep yep... it's throwing your internal amp into... "protect" i guess you would say... if you have a really bad speaker it will do it... or a terminal touching ground or a wire grounding out then it will do it as well... check all your wiring behind your deck and at your speakers... best would be to get a DMM with a continuity setting that beeps... then you could put one meter lead on ground... and the other on each speaker wire til you find one that beeps... then that's the wire that's grounding out

05-11-2005, 11:47 PM
i had a sony xplod hu and it cut out at loud volumes and when it got hot i tryed everything but i turned out i didnt have a stong enuff ground for the hu.