PDA

View Full Version : Kenwood KDC-X817 Problems



grneyz2nv
10-01-2004, 09:29 PM
My CD deck has started to act out of sorts. Nowdays when I turn on the truck the faceplate flips down and just sits there, I can't even get the CD out! Then, if I remove the faceplate it folds back up like normal, but if I replace the faceplate it just does the same thing. Has anyone seen this before?

brandontw
10-03-2004, 11:04 PM
hmm sounds defective to me

grneyz2nv
10-04-2004, 10:31 PM
I have had it for over 2 years. The only response I got from kenwood was send it to us so we cn look at it.

If ideas will help

Thanks!

VOA_NIGHTMARE
10-10-2004, 07:15 PM
Send it in and have them test it. If its in good shape its well worth it. I have the x711 and I have not had a problem with mine but if I was keeping it, I would send mine in to have it checked and cleaned up. I think mine is well worth putting money into if I had the problem you are having. But it up to you on how much you like that h/u

jdrockafella
10-10-2004, 10:39 PM
have you checked to make sure your switched +12V supply fuse isn't blown? Sounds like you have only constant power to it. Or it's just defective.
just a thought

forty4
10-20-2004, 03:00 PM
Did you ever get your hu to work?? I have a kdc-x715 and it just started doin the same thing. Just wanted to know if you got yours to work. From lookin on the internet its a pretty common problem. The most iinformation ive come up with is a kinked spring or something. I dont have the option of sending it to the factory because i bought my car with the cd player in it. Thanx for any help.

Buffulax
10-21-2004, 06:43 PM
Mine has the exact problem, Don't know what to do to fix it

bmpngrandam
10-22-2004, 08:33 PM
What is up all? This is my first post.

Anyways... my friends deck did the same exact thing... then the guy (at advance audio in wichita....Worthless in my opinion) told me it would be $325 minimum to fix. Since the deck was now worthless i decided to work on it. Someone apparently had hit the deck while it was off and it cracked one of the plastic clips that held the back part of the faceplate on tight. Since that was loose it was catching whenever it tried to flip. I just removed the faceplate and used scotch tape to hold it together tight. It works fine and for a total of $0 i now have a new head unit. If you dont understand i can try to post pictures... It might not be the same thing but its worth a try.

Later guys

Jared (bmpngrandam)

aznpulse
09-22-2005, 04:30 AM
Hi! I just so happen to have the KDCx859 Head Unit and I was wondering about the problem. No one has really come up with a solution to this problem. I believe the unit is powered up and everything and obiviously it's working because the face flips out and everything. If someone could help me with this situation. I'd greatly appreciate it.

scrappy
09-22-2005, 08:47 PM
I had the 817 itis the ribbon that flips the face. I beleive it eventually gets pinched or something like that. I just bought a new one but I heard that you can get a new ribbon and replace it