PDA

View Full Version : Am I underpowering these subs?



Wes2020
09-05-2004, 02:04 AM
I am quite new to car audio and i have a few questions, so forgive me...\

Right now i have 2 audiobahn Alum12Q's ran by an an audiobahn A18001DT amp

i beleive the subs are rated 1000 rms each and the amp is 1800 rms

so my question is is that too big of a difference? How do you know how much is to much over the rms rating?

would 2200 rms be to much for a 1800 rms amp?

jellyfish420
09-05-2004, 02:14 AM
you'll be fine. if under powering was a real prob, then you would have to worry every time you turned it down, wouldn't you.

CarlB
09-05-2004, 08:48 PM
Your system should be fine. Depending on your enclosure, you might be at the mechanical RMS of the sub anyway (it might be reaching full excursion, and any more power would just heat the voice coils)

Jamesr316
09-11-2004, 07:25 AM
I got the same amp and sub, except I only have 1 sub. let me know how you like it.

Im guessing you are running them with a total load of 3 ohms? If so, each speaker is getting around 450 watts which should be ok

OLD_SCHOOL
09-12-2004, 03:07 AM
i never understood this? am i underpowering the only time i could even see this becoming an issue is if the sub is not moving enough to cool it's self Ie putting 100 watts to 1600 rms sub or something.

clipping and the like is user error not under powering error

said it a 1,000 times ang jelly said it for me already here not a problem when you turn down the volume is it ?

JimJ
09-12-2004, 03:28 AM
only time it's an issue is when you're clipping the amp, so you're actually sending more than the rated power of the amp to the subs. Then you run into problems, but that's not clean power...so all bets are off.

OLD_SCHOOL
09-12-2004, 03:32 AM
only time it's an issue is when you're clipping the amp, so you're actually sending more than the rated power of the amp to the subs. Then you run into problems, but that's not clean power...so all bets are off.

and again thats not an underpowering issue that a "user needs to quit hitting the volume up button " issue