PDA

View Full Version : tweets go flat very often, why??



jonb5150
06-30-2004, 01:13 AM
for some reason when i listen to music in my car the treble sounds as tho it cuts out from the front tweeters. I got cdt 61a in the front with silk dome tweets. The xovers are set to 3db increase but i 've tried them on all settings. Also, the amps gain is at a modest level say around 70 wrms.

Tweets are still playing music but they sound noticeably flat...sort of like holding a pillow overtop of them. When i turn volume down for a few seconds they tend to sound normal again.

Any ideas?

PV Audio
06-30-2004, 08:33 AM
probably just clipping

slick rick
07-01-2004, 01:21 PM
It's possible that your x-overs have tweeter protection circuitry and it is cuttting out the treble to prevent you from damaging your tweeters ... My advice is to turn the x-over setting down to 0 dB and make sure your amp isn't clipping ...

yes his x-overs have that. according to cdt if they cut out they will come back on at 80% for a few hours.. then back to normal.

desi_daru
07-01-2004, 04:01 PM
for some reason when i listen to music in my car the treble sounds as tho it cuts out from the front tweeters. I got cdt 61a in the front with silk dome tweets. The xovers are set to 3db increase but i 've tried them on all settings. Also, the amps gain is at a modest level say around 70 wrms.

Tweets are still playing music but they sound noticeably flat...sort of like holding a pillow overtop of them. When i turn volume down for a few seconds they tend to sound normal again.

Any ideas?

amp gain is set to around 70w rms???? amp puts out same wattage i beleive at all gain settings (if im wrong correct me plz), u jus need to set it to voltage level that the pre-outs on the deck give, so like all the others have said most likely clipping