PDA

View Full Version : Started the install



JustGotOne
06-07-2014, 07:33 AM
I started the install yesterday, got a late start so I wasn't able to do as much as I would have liked. Rather than pull the radio, I disconnected the rear door speaker connections and ran them to the LOC. Then laid out the wire going to the rear doors from the amp. Today I'll run the wire from the amp to the front set of speakers, and power cable. I only took a few pics. Not the best pics, sorry about that, I'll try to get better shots today.

JustGotOne
06-10-2014, 05:45 PM
I didn't do a good job keeping track with pics like I wanted to, I have a few more to share (they are on my phone) will do that in a day or so. Not that it's anything special , just want to contribute my two cents. for the most part the install is completed with the exception of trimming wire in the compartment where the amp and Audio Control Lc7i are located. I still also have to decide on whether to build or buy a box for the subs. I'm using the old box I had with the 12" Kickers until then.

JustGotOne
06-30-2014, 11:57 AM
Here's the rest of the pics of the install, i still have to install the cooling fans for the amp, which I will do today or tomorrow before the wife and kids take the truck south for the 4th, I was also thinking about changing the cover on the compartment to a clear acrylic I think it would be a nice touch with the blue neon in the fans. I've attached the rest of the pics. In the pic where I have the fans sitting is where I'm planning on installing the two I want to blow directly on the heatsinks, I'll have another I'm thinking at the end where the Lc7i is will be the other to use as exhaust. I'm going to tap into the accessory socket at the second row as it is only on when the truck is on, and I have thermal switches that are normal open and will close when the temperature gets to +-5 deg.

If you happen to look at this and have another idea that might work out better for cooling throw them at me.