PDA

View Full Version : My speakers dont sound that clear



southport2014
04-15-2014, 10:15 PM
I have a set of component speakers. They are morel maximo 6.5s They are currently being ran on a kicker 650.4.
They don't seem to be that clear. I really don't know how to tune the amp and radio I have that well.

The radio I have is a kenwood excelon x996.

I currently have the amp gain at a little under half. The Bass boost at 1 db out of 16 or 18
and the frequency at 100hz.

The headunit has a manual 13 band eq but I just have it set under the rock setting.

Can anyone tell me how to get the best sound out of my speakers? thanks

Cliff459
04-20-2014, 02:25 AM
Have you checked the crossover output wiring? These speakers are VERY polarity sensitive on the output of the crossover, as a 2nd Order design is 180 degrees out of phase at the crossover point and these crossovers will have the polarity compensated because of this. So, double-check that the crossover OUTPUT polarity exactly matches the driver INPUT polarity, ie + to + and - to - on both drivers. If the polarity isn't right, there will be an extreme dip at the crossover point, which will definitely give a strange sound to the system.

Double check all the settings in your head unit, and make sure they are correct. I have an older Kenwood head unit that has PAGES of settings, it took me quite a while with the printed manual in hand to go all through them. If in doubt, do a "factory reset" of the unit and start over with the settings. I have attached the Kenwood manual picture of the "reset" button to my post.

Hope this helps you!

jeffdachef
04-20-2014, 03:29 AM
http://www.caraudio.com/forums/car-audio-build-logs-cars-trucks-suvs/536049-2001-accord-ex-sedan-its-long-3.html do your door treatments. Make sure your wiring is correct, make sure they are connected on the proper channels of the amp.