PDA

View Full Version : Help! Blown speakers? Defective headunit? Amp issue? Audio distorts when increased.



Infligo
03-21-2014, 10:52 PM
About a year ago I bought Kenwood KDC-BT752HD radio headunit for my 2005 Chrysler Crossfire SRT-6. I bought the necessary wiring harness and had it installed. Whenever I increase the volume it gets distorted until you're unable to hear any music and it's just noise. It worked perfectly for a while, except sometimes it would do what it is doing now, but I found that when I opened and slammed the door it would fix this, but not always. Then about 6 months ago it decided to crap out on me and now it is always like this. At first I thought it was my speaker's, but then someone who has had some experience with speakers and radios told me it's very rare that both speakers would blow at the same time, and that in fact it is a problem with the headunit or maybe amp? So I called the company to use the warranty and return the device when they gave their opinion and said that maybe the radio isn't using the car's amp and that's why it distorts when it gets louder. I thought that made a lot of sense, so I didn't return it. But if it is the radio not using the amp, then how did it work before? So do you think the amp is just blown? Or a fuse? I would greatly appreciate any help from someone who has had experience with this kind of thing before. I hate not being able to listen to music properly while driving. Thank you so much!

I recorded it and uploaded it to youtube for you all to see.

https://www.youtube.com/watch?v=N-bDfK3Ahz0&feature=youtu.be

hispls
03-22-2014, 12:03 AM
Likely something shorted out (bare wire touching bare wire, or bare wire touching metal)

calebkhill
03-26-2014, 09:43 PM
Sounds like speaker wires are crossed