PDA

View Full Version : JVC KW-ADV64BT Issues



06camarodude
03-01-2014, 05:47 AM
Hey guys, long time lurker, first time posting here though. I have a JVC KW-ADV64BT in my '05 Malibu LS (daily beater), and I've been having issues with the stereo for a while, just wondering if there's anything I can do to resolve the problems.

First problem is the call quality when using the bluetooth hands-free calling feature. Audio through the car speakers is great, and I have no complaints, but the microphone is lacking severely in terms of transmission quality. 9/10 times, I have to use the phone itself because the person on the other end can't understand/hear what I'm saying. I've been told it sounds like I'm speaking into a tin can, road noise is overwhelming, or it sounds like I'm too far from the mic. Microphone gain is set at +2, microphone is mounted to the top of the A-Pillar trim where it meets the headliner, maybe 12-18 inches from my face. Previously, I had it mounted in the location for the factory OnStar microphone (inside the trim panel around the front map lights), but wind noise from the roof was too much, and it didn't work well. I've tried mounting it to the gauge cluster trim (too far from face) and the center stack above the stereo (farther yet). The current location seems to work alright, but I'm wondering if maybe the gain is too high, or if I need to replace the microphone, instead of using the one that was bundled with the head unit.

Second issue, when my phone (iPhone 4S) is connected via USB in "iPod Mode", if I use the iPhone to select a song, the JVC will display the correct artist and album name on-screen, but displays the wrong song name. Playing audio through Bluetooth displays the correct information, and using the iPod Head-Unit-Control mode displays the correct information, but disables song selection from the phone itself. Bluetooth mode is what I've been using, since I often have passengers, and I like them to have the ability to skip songs and play/pause audio from the head unit, and I can select specific songs from the phone. I'm not using the KS-U30 iPod cable, I'm just using a standard iPod charging cable plugged into the stereo's USB port. I had the JVC iPod cable, but the solder joints at the iPod connector end failed, and the cable stopped working after about 2 weeks. I didn't want to shell out another $30 for a junk cable.

Aside from that, it's been a great stereo. I have a Garmin GPS unit I use for work, so I didn't bother paying for the app that allows navigation display on the JVC unit, since that app lacks some of the features I needed. I'm fine with using the Garmin, it was tax-deductible and can be transferred to different vehicles. I haven't messed around with any of the high-speed features of the stereo, I use it mostly for playing music, although I'd like it to display the correct song names, and it would be great if the Bluetooth Hands-Free calling worked well enough to be functional. I'm not looking for perfection, but if I could get the performance that some of the new vehicles have from their built-in bluetooth setups, I would be happy.

I'm not opposed to getting another stereo, I like the JVC, but I realize it's a couple years old, and there are probably nicer stereos out there, but unless I'm going to see an improvement in the bluetooth function, it's just not worth it to me. My next car will have factory Bluetooth hands-free and USB functionality, so I likely won't mess around with it in the future, but I'd like to know what I've been doing wrong all this time.