PDA

View Full Version : Time for a new deck..??!!



tc300
01-18-2014, 07:42 PM
I have a alpine cda-7892 in my grand prix, I've had a humming/rumble sound that's more pronounced through my sub which I thought was a bad ground.. I cleaned up the wires and checked all connections and the sound is still there.. You can also hear a hiss through my highs I have a kicker 2 channel for comp set.. I even tried new RCA wires un-ran, just pulled the deck out the dash and ran them to the amps to see if it would fix the problem. Nope! Today I hooked up my iPhone to the amp (3.5 jack to RCA) and the sub doest have that rumble sound any more at idle..

So could it be my deck is goin bad...??!! It's about 10 years old and I know stuff don't last forever!

---------- Post added at 03:42 PM ---------- Previous post was at 03:41 PM ----------

Any thoughts or help would be appreciated!! THANKX.

tc300
01-20-2014, 09:46 PM
????

snoop3111
01-20-2014, 10:36 PM
Did you check the ground on your HU or just the amps?

tc300
01-21-2014, 01:36 AM
Did you check the ground on your HU or just the amps?

just the amps... its the only deck thats ever been installed in the car. was done by a good shop also. the deck is close to 10 yrs old... the age of it is why im thinking its going out.

Side Show
01-21-2014, 01:48 AM
I'd say it's the rca connections behind the headunit, make sure none of your other pwr wires ect for the headunit wiring arntnear the rca connections. how many pairs of rca's have you got run to the rear?

snoop3111
01-21-2014, 02:06 AM
Something must have changed for noise to be introduced. Try a new HU and if that's not it, triple check all wires and connections.

Side Show
01-21-2014, 02:44 AM
reset headunit?ipod

tc300
01-21-2014, 05:02 AM
I'd say it's the rca connections behind the headunit, make sure none of your other pwr wires ect for the headunit wiring arntnear the rca connections. how many pairs of rca's have you got run to the rear?

I bought new rcas and pulled the deck and left it out when I tried the new rcas, the sound was still there.. The ones that are ran in the car are stinger HPM3 6 channel. The one channel that isn't being used are taped off...
This alpine has about 4" of RCA wiring that comes out of the deck so I guess I could pull it out and check that mess!!