PDA

View Full Version : WACK sounding setup ... think its mainly my speakers ... help ?



skwidstyle
08-09-2013, 12:04 AM
ok so i have a pioneer deh older decent quality deck with a 7 band parametric (not one of the cheaper ones avail. at walmart). it sounded pretty decent just hooked up to 2 mid to low quality punch 40 watt rms coaxials in front doors & 2 mid quality alpine 80 watt rms in rear doors. now i hooked up a jbl gto 4 channel that pushes 80 watts rms to each of the 4 channels at 4 ohms, which all speakers are 4 ohms (100 watts/channel rms at 2 ohms). at first, it honestly sounded no "louder" at all, basically the same. i set the gains with the tone cd to where they are green for both front & rear. after about 2-3 days, the "loudness" or volume still sounds identical to just the power from the deck itself, yet even at lower volumes the highs just hurt my ears.
... now from what i have gathered, i believe that higher quality speakers with a 93-95 db rating (both sets of current speakers are 88db) would make a noticable difference in volume & sound clarity & would get what i expected out of that amp. my question is am i right in my way of thinking, that replacing the speakers will in fact give me the sound i was expecting from the amp? i was looking into replacing all 4 speakers with either INFINITY KAPPA 62.11i 6.5" - RMS Power Handling: 5-75 watts
Impedance: 2 ohms
Frequency response: 45-25,000 Hz
Sensitivity: 95 dB
... OR... HERTZ® ECX-165 6.5"
Sensitivity: 93dB/SPL
Power handling: 140W Peak / 70W RMS
Frequency Response: 60Hz-23kHz
Impedence: 4 ohm
... opinions? facts even better from those who know?

gckless
08-09-2013, 12:19 AM
That's WACK

Wrong section, which is WACK

skwidstyle
08-09-2013, 12:29 AM
thanks for the reply stating that i'm in the wrong section ... so do you have the courtesy to show or tell, someone like me who obviously is lost & in the wrong section according to you, what the proper section is ? or do you just enjoy telling people how wrong they are in whatever it may be ? hey ... just asking!!! ya know, since your reply basically fits the description of uhmmm.... how i described it ... ???

des343
08-09-2013, 01:04 AM
thanks for the reply stating that i'm in the wrong section ... so do you have the courtesy to show or tell, someone like me who obviously is lost & in the wrong section according to you, what the proper section is ? or do you just enjoy telling people how wrong they are in whatever it may be ? hey ... just asking!!! ya know, since your reply basically fits the description of uhmmm.... how i described it ... ???

No he just had nothing better in life going on so he thought he would troll

Unfortunately I don't really have any expirence with 4 channels. But maybe you have the speakers wired wrong or out of phase? Or maybe you have a bad rca connection for some reason

skwidstyle
08-09-2013, 01:49 AM
i have decided, no matter the reason (heck maybe it sounds great to someone else lol...) to go forth with replacing the front cheapo punch coaxials as a start, as the alpine rears are actually pretty decent speakers (the 88db i do think is a little low but i mean they're not bad). which would you recommend out of the 2 i have posted ... & also would i notice a total step up in sound if i just went with HERTZ HCX-165's, taking into consideration i find out for sure my amp IS in fact setup properly & working properly ?

drummer4261900
08-21-2013, 07:43 PM
good stuff!!