PDA

View Full Version : Tweet pair help



Oraclem19
06-25-2013, 03:36 AM
Recently got a pair of older (not sure how much) 6.5 cs Phoenix golds on here, along with the crossovers that came in the set. Tweeters were not included.
Back of the woofer says something like 120w max, 100 w rms, along those lines. The current line is rated for 150wrms, and has 2 switches inside the crossover.

Given that I have the crossover, do I need to find a 100w (ea.) pair of tweets to put with this set to keep from blowing at max? Or is there some hidden tweet/woofer rms rating ratio that comes from the crossover?
The speakers sound great, even with a temp door seal from roof flashing, fiberglass, liquid nails, and pns. Get a little muddy up near the top end of things though. I would imagine that is from the crossover not having a tweet to send the upper signal to. Or maybe I'm not used to it.

Although a question to anyone who owned this series, current manual has 2 switches (midbass and tweet), I can't find an archive of manuals, and this crossover only has one +2db switch. Would it be safe to presume that is midbass? IIRC tweet is usually a -3db switch.

Thanks all for any help. Very pleased, can't wait to get better quality amp, actually turn them up to full, have tweeters, and get quality deadener.

keep_hope_alive
06-25-2013, 04:30 AM
key for adding tweeters is matching the impedance and size/response of the originals.

Oraclem19
06-25-2013, 04:32 AM
Spec sheet I have does not even have specs for tweets. Contact Phoenix gold and try to get a sheet?