PDA

View Full Version : JL 900/5 review



Rockguy475
04-12-2013, 07:55 PM
Review of Amplifier:

<i>Post name, details and review of the equipment you're reviewing. This forum is for reviews only! No questions should be posted!</i>

JL 900/5 review!

So I have had my system up and running for a good 2 weeks now and am very very impressed with my amp which is powering EVERYTHING. Was not a believer in 5 channel amps as I was always told 2 amps was the way to go but JL has changed my mind.

Dont be fooled by the size of the 900/5... it looks tiny but it is a BEAST. Pushes 900 RMS easy and that is probably underated. Would highly reccomend to anyone trying to power 4 seperate speakers along with a sub. I have all 4 speakers at 4 ohms receiving 100 rms each and my sub at 2 ohms getting 500. The sound qaulity is great I cannot stress this enough. The ONLY downfall about this amp is the price.... if you want to buy one with the JL warrenty expect to drop around $800 but if your willing to take the risk and buy one without it you can probably find one brand new for $600.

All in all this amp kicks major *** and I feel it was well worth the purchase especailly if your looking for a great sound quality system. Go pick you up one of these bad boys or any other of their HD series amp, you will not be dissapointed.

NoLoud4U
04-12-2013, 08:27 PM
You don't hear any cut off in the highs? 10000+ range? I always did with the HD amps when they where pushed hard. The only reason I didn't get them instead of the / was they took off the awesome CO section. They made them plug and play

kramer_212
04-12-2013, 11:08 PM
yeah that amp is a beast put in about 5 or so every time its mind blowing, even at 12v does the same power

Rockguy475
04-13-2013, 06:50 PM
You don't hear any cut off in the highs? 10000+ range? I always did with the HD amps when they where pushed hard. The only reason I didn't get them instead of the / was they took off the awesome CO section. They made them plug and play

The only problem I have run into so far was the first amp they sent me had a front right channel defect but it was all covered by warrenty so they sent me a new replacement promptly. My new amp works great. Havent had my highs cut out at all. What do you mean by the 10000+ range? I probably have not pushed it as hard as you did but I do get my sub to slam pretty solid... probably bc of my box too though. 500 rms to a sub is plenty for me in a 4 door sedan

NoLoud4U
04-13-2013, 10:16 PM
The only problem I have run into so far was the first amp they sent me had a front right channel defect but it was all covered by warrenty so they sent me a new replacement promptly. My new amp works great. Havent had my highs cut out at all. What do you mean by the 10000+ range? I probably have not pushed it as hard as you did but I do get my sub to slam pretty solid... probably bc of my box too though. 500 rms to a sub is plenty for me in a 4 door sedan

10000hz range. They have all sound rather bland on the high highs. Those and the 600/4.

Rockguy475
04-15-2013, 07:03 PM
10000hz range. They have all sound rather bland on the high highs. Those and the 600/4.

Hmmm I really haven't noticed anything bland about the sound. At really high volumes they still keep clean in my ride. Everyone that as been in my car has been very impressed. Could have been the speakers you were using?? I'm pretty big in sound quality and would notice if they started to fault especially at higher volumes.