PDA

View Full Version : can you please help ?



luis_88
03-16-2013, 04:07 PM
I placed an order today but i accidently backed up and now it's asking me to pay again , please help as i was not able to put my tracking information but payment already went through.

audiobaun
03-16-2013, 04:09 PM
I placed an order today but i accidently backed up and now it's asking me to pay again , please help as i was not able to put my tracking information but payment already went through.

make a simple Phone call to get it cleared up:uhoh:

luis_88
03-16-2013, 04:20 PM
I did call and it says if any specific question please email them, if you keep listening its press #3 (http://www.caraudio.com/forums/usertag.php?do=list&action=hash&hash=3) if anything else. I did so and said a represenative well get with you in a 90min period. . . and then it goes back to the first calling page giving you options again :help:

audiobaun
03-16-2013, 04:24 PM
I did call and it says if any specific question please email them, if you keep listening its press #3 (http://www.caraudio.com/forums/usertag.php?do=list&action=hash&hash=3) if anything else. I did so and said a represenative well get with you in a 90min period. . . and then it goes back to the first calling page giving you options again :help:

Id call my bank/or CCard company, and cancel the order..Find another source to buy from thats had no issues with customer service.There are approx. Ten recommended car audio sites to buy from on here, as well as several recommended vendors that are available to purchase from,that have great customer service

luis_88
03-16-2013, 04:28 PM
Just checked my bank account, i got the the money back in several minutes! it was a total user failure and none with the vendor, have bought couple item's just for my DD. sorry for all this trouble guys.

audiobaun
03-16-2013, 04:36 PM
Good deal there man

3 Kings
03-21-2013, 01:58 PM
Hey there-

Extremely sorry about the delay in response, it's been all kinds of crazy busy around here lately. Glad it was resolved, I know we're having some issues with this sort of thing - may I ask if you used a debit or credit card?