PDA

View Full Version : Sounds like sh*t



cfox10
02-15-2013, 09:49 PM
I sealed up the doors in my girlfriends car and put my Polk db6501's in her ride... I upgraded myself so I passed these on to her. I put them on my Coustic 510DR and they are running from an old 3100ub Pioneer.


Long story short, no matter what adjustments I make the the eq, they sound like crap. Could the 2v preouts have anything to do with this? They aren't distorting like they have too much bass or anything, just sound awful. HPF set to 100, no sub while adjusting.

obxsurfisher
02-15-2013, 10:04 PM
It doesn't distort at all? Like, what are they lacking in sound that makes em sound like shat?

cfox10
02-15-2013, 10:06 PM
Haha.... maybe a little bit of distortion but to be honest, they aren't getting louder or cleaner than off the head unit?

The doors are in a Honda Civic and I sealed them off from the door itself (like a pod) I have them crossed the best I can off that head unit.

obxsurfisher
02-15-2013, 10:10 PM
I don't think the 2 volt output on the hu would be the culprit, but i could be wrong. Is everything wired correctly? Is it just 2 speakers you installed or more? Also, the amp's a 2 channel right?

cfox10
02-15-2013, 10:16 PM
It's 2 ch. with balanced inputs... which I'm not utilizing due to headunit. It's wired correctly, I knew I was disappointed with these speakers before but not this much....

Tweets and mids in the stock locations, wired with the passive crossover w/ 0db increase. If my amp had xo settings I'd run the mids and tweets separately and cross them over at the amp, but it doesn't. I used audiotechnix sound deadener.

obxsurfisher
02-15-2013, 10:19 PM
I don't know man, hopefully someone else will chime in on this. Sounds like you've done the best you can though. Good luck

Thumpersplbassx
02-15-2013, 10:30 PM
How did they sound in your vehicle? Did you wire them up right? They might be out of phase.

itsblown
02-15-2013, 10:32 PM
hmm What exactly is lacking have you tried using different sources for the music like an ipod or a cd and then radio

cfox10
02-15-2013, 10:34 PM
How did they sound in your vehicle? Did you wire them up right? They might be out of phase.

They sounded ok.... but it may be that I've been spoiled with my components running active from the 80prs... They seem super harsh on the tweets and severely lacking in the midbass, and if i eq them up on the mids, they distort like crazy.

cfox10
02-15-2013, 10:35 PM
hmm What exactly is lacking have you tried using different sources for the music like an ipod or a cd and then radio

I know the first stuff I tried was a flash drive with her music... which I realized were encoded at something low like 124kbs... so I checked some CD's out, sound is better but still not great.

ThatChevyGuy
02-15-2013, 10:40 PM
turn all filters on the deck off, they ****.

cfox10
02-15-2013, 10:47 PM
turn all filters on the deck off, they ****.

It's on custom eq, I have to choose what they are on. Other than that, the amp doesn't have built in crossovers and the passive ones for these components don't do a very good job. They are running off 100rms each... which at 100hz I thought they would handle fine. Meh.

itsblown
02-15-2013, 11:35 PM
hmmm maybe too much expectation?

cfox10
02-16-2013, 02:53 AM
Meh, too much expectations for sure. It's good enough for her, I dropped in 2krms and she said too much.. so, dropped down to 300rms on the 12w3 laying around. Sounds good to her and the w3 crossed over around 120 does really well keeping the mids sounding good.

alexn09
02-16-2013, 03:05 AM
Hey how did you seal these off from the doors? I've seen people install foam baffles, call them pods, and then have extremely lacking midbass due to too much air pressure choking the cones.

mlstrass
02-16-2013, 03:38 AM
Turn up SLA a few clicks on the PIO hu so you get full pre out voltage. Made a world of diff on the few 2v Pio's I've messed with...

cfox10
02-17-2013, 02:54 AM
Turn up SLA a few clicks on the PIO hu so you get full pre out voltage. Made a world of diff on the few 2v Pio's I've messed with...

SLA def. made it sound better. It was super quiet compared to radio, adjusted everything to match and it sounds much better. Thank you sir!

mlstrass
02-17-2013, 04:11 AM
SLA def. made it sound better. It was super quiet compared to radio, adjusted everything to match and it sounds much better. Thank you sir!

NP :cool: