PDA

View Full Version : Eclipse CD3200 HU screen help please!!!



Chollis
01-09-2013, 07:13 PM
I recently purchased an Eclipse CD3200 and about 20 minutes into messing with the EQ and such after the install, the screen started to fade slowly until it was all black. Now, the 4 main buttons work, but the screen is black. After checking and double checking to make sure that it wasn't something with my wiring, I thought that maybe the screen just burnt out. I got a replacement faceplate, but it's still doing the same thing. Is there some specific part that usually goes out on these things? Has anyone ever run into this problem with this head unit, or this problem in general? Is there something in the receiver that blew or needs to be replaced? How can I fix this? Please help me out, give me some clues as to what it could be...

lapycaraudio
03-19-2013, 12:43 AM
Is there some specific part that usually goes out on these things? Has anyone ever run into this problem with this head unit, or this problem in general? Is there something in the receiver that blew or needs to be replaced? How can I fix this? Please help me out, give me some clues as to what it could be...

I just sent my CD3200 and faceplate to United Radio in NY for similar symptoms. Faceplate buttons seemed to work, but display was black. They reported that they couldn't fix it as apparently there were burnt out components in the HU. I'm curious as to where you found one to install at this point? I found your post as I was just online searching to see if there were compatible Eclipse HU's that might fit the same opening and possible use the same Lan and main rear connectors. I'd like to keep the Sirius/Ipod/amp setup. Anyone know if there are newer Eclipse HU's that might work? It would be even better if someone really could fix these HU's.