PDA

View Full Version : no subwoofer option



emd023
01-04-2013, 02:58 PM
Just picked up a kenwood kdc-152. It shows in the manual that there is a subwoofer option but it is missing from the actual head unit. anyone have an idea why the option is missing? my subs are hooked up and are working fine.

T.I.K.
01-04-2013, 03:33 PM
Just picked up a kenwood kdc-152. It shows in the manual that there is a subwoofer option but it is missing from the actual head unit. anyone have an idea why the option is missing? my subs are hooked up and are working fine.
Did you check to make sure your HU manual doesn't have instructions to turn it to "subwoofer mode"? I know there are several headunits out there that have independent subwoofer control, you just have to turn it on.

emd023
01-04-2013, 08:22 PM
yeah. i checked and there is nothing.

CJL
01-04-2013, 08:43 PM
Try turning the unit off with the SRC button then press in and hold the volume knob to access the other menu.

trumpet
01-04-2013, 09:08 PM
Try turning the unit off with the SRC button then press in and hold the volume knob to access the other menu.

Yup. Kenwood done effed up with this weird operation.

B-Sh0t
01-04-2013, 09:09 PM
http://a248.e.akamai.net/pix.crutchfield.com/Manuals/113/113KDC152.PDF
I'ts like a jvc HU

emd023
01-06-2013, 02:47 PM
no luck. i guess ill have to call kenwood.....

emd023
01-06-2013, 02:56 PM
fixed it. called kenwood and they made me go thru a bunch of steps to enable the subwoofer option. retarded. why was it disabled in the first place?