PDA

View Full Version : Pioneer AVIC Z1 unresponsive?



bradfordp2612
11-29-2012, 03:02 PM
I bought this unit when it had the Z1 software on it and once I got it I had a shop install it into my 2007 Silverado. I also had the iPod interface and SWI-PS installed as well. Once I received it back it was working properly but I read up on doing the Z1 to Z3 upgrade so I took the HDD out and sent it to Garret. Once I received it back the unit started acting funny. When the unit was powered on and updated I was having trouble clicking the "OK" button on the "Regional Settings" menu when it is booted up for the first time. After just random pressing all over the screen the OK button finally responded and it went to the Map. I then tried to press buttons on the screen but they wouldn't have a response and I couldn't do anything. I then contacted Garret and ran through some troubleshooting steps but had no luck as to why the touchscreen was unresponsive. I then tried pressing the physical buttons on the outside of the unit and the buttons "Menu", "AV" and "Map" wont do anything once I press them. The only way I can control the unit is through the steering wheel controls.

I then cleaned off the screen and tried some more stuff but I couldn't get it to act right. I uploaded a video of the problem I'm having to show what is going on as it is kind of difficult to explain.

At first I couldnt get any of the buttons to press but it randomly accepted one click on the "Seek" button then nothing else. At the end I also show how quick and accurate the steering wheel controls are with the unit.

What in the world is going on? I've read up a little bit and some say it could be the SWI or it might be a ribbon cable that connects the screen to the brain of the unit. Has anyone else ever seen this before?


http://i743.photobucket.com/albums/xx77/bradfordpoole/th_IMG_0559.jpg

UPDATE 1:
Alright just went out to my truck and fire it up and it was working perfect for about 5 in and then started messing up while I was sitting in the Wendys line.


UPDATE 2:
I did some research and some say it might be the ribbon cable? When I'm in the test mode I can control the menu when the screen is in the down position but when I put the screen in the up position i can press the P.LIST buttons about 3 or 4 times then the buttons stop working again.

Really need to figure this out before I dissamble something..