PDA

View Full Version : KenWood KDC 138 Skipping



Jerhemy
10-13-2012, 07:07 PM
I have had this head unit (kenwood KDC 138) for a couple years and it ahs been installed in 3 different vehicles. Just recently it has started skipping when the bass gets loud enough. It is difficult for me to get repeated results, but it does not sound like a signal issue, but a CD skipping. It also does not skip when I use the AUX port.

Is there anything I can do to stop the reader from skipping? Or is it just time to get a new deck?

Would something like an Alpine CDE 123 be a better choice?


Thanks for any help


KDC 138
Kenwood KDC-138 Car Stereo (KDC138) - Sonic Electronix (http://www.sonicelectronix.com/item_10339_Kenwood-KDC-138.html)


CDE 123
Alpine CDE-123 (CDE123) DIN CD Receiver w USB Front Aux & Pandora (http://www.sonicelectronix.com/item_34353_Alpine-CDE-123.html)

Jerhemy
10-13-2012, 07:11 PM
or the alpine CDE 136, as the CDE 123 is discontinued
Alpine CDE-136BT CD receiver at Crutchfield.com (http://www.crutchfield.com/p_500CDE136B/Alpine-CDE-136BT.html?tp=5684)

jockhater2
10-27-2012, 09:24 AM
If it is skipping when you have CD's in. It is most likely the bass causing it to skip. or bumpy roads.


I'd sell you my Kenwood Excelon KDC-X895 CD receiver at Crutchfield.com (http://www.crutchfield.com/S-wXW8CSPlzSk/p_113KDCX895/Kenwood-Excelon-KDC-X895.html)

You would receive it in 1 day most likely since were only about 3-4 hours from each other.
The deck is really nice. I tested it with the 0db 40 hertz and 1khz tracks. HU never clipped even at volume 35/35

I am not really too concerned with selling it. Just thinking about trying out that pioneer 80prs.