PDA

View Full Version : Worm needs help finding dirt



texastea
09-15-2012, 10:19 PM
Hi everyone I am a newbie in every sense of the word, when it comes to this car audio.If you don't mind I could use some info from someone, who can at least tell ya what a crossover is!Here is what I need help with please bear with me.I recently purchased an 02 avalanche 1500 w/onstar and a factory stereo.The speakers were all blown so I decided to replace.So I bought two sets of infinity kappa60.9cs 1 set for back and 1 for up front.Purchased an infinity 475a 4 channel amp to drive it.I had this professionally installed ( for 457.00) I might add but they rewired the doors also so The thing is it sounds absolutey horrible.I am told to up grade head unit.Is the head unit from factory that bad.Heck the old speakers that came from factory sounded better.Is it becauce I now have so much more power that you hear so much distortion or something the tweeters which he mounted up high by your ears in the back I think make more noise than music.Can the head unit be to blame I swear it sounded better 1000.00 $ back with cheap speakers.If it is What would you recommend.I have been narrowing it down with SOUND QUALITY and of course MONEY as main factor so we talk single din which lead me to pioneer or kenwood .Any help or advice would be deeply appreciated.I hope everyone is having a great year.Where I live in southern us it has been a hot DRY year and we finally ,(repeat) finally got some decent rain.At least it will help for next year! see ya and thanks

UnderFire
09-15-2012, 10:22 PM
Sounds like the speakers aren't properly crossed over to me. Is there a lot of distortion in the bass?

dragnix
09-15-2012, 11:11 PM
I'll help you if you help me. Put your writing in proper paragraphs or else no one will want to read it. Give me a summary at least

Flex68
09-16-2012, 12:12 AM
word

05fronty
09-16-2012, 09:35 AM
lol

texastea
09-16-2012, 04:49 PM
There is a lot of distortion in bass and tweeters.The speakers would go eardeafening loud but you can't stand the distortion after a quater loud.Thanks

---------- Post added at 02:49 PM ---------- Previous post was at 02:49 PM ----------

sounds like your into that

texastea
09-16-2012, 04:59 PM
I do believe I joined the wrong forum sorry I cannot take type proper that is not what I was here to learn If you could not figure out the prob from what I wrote I am astonished.I do believe that I articulated my problem well ehough for a person to get an idea as to what my audio problen is.If my use of paragraphs throws you off course of the issue at hand then I am obviously communicating with the wrong person.Thanks anyhow but I am here for audio help.Not proper sentence structure.

av83
09-16-2012, 06:05 PM
Sounds to me like a bad install. Have you gone back and asked why you paid a lot of money just for it to sound bad? Have you told them that you can't wait to show all of your friends, family, and associates just how awful a thousand dollars spent at their shop sounds? There are many different things that could cause the new equipment to sound bad.. But it is all install related and would be their fault anyway. It should sound good if it were installed correctly, even with a stock headunit.

Flex68
09-16-2012, 10:37 PM
I am here for audio help.

GL with that, now, youngster.


I do believe I joined the wrong forum.

Travel anywhere and show no :respekt: and you'll get to do alot of traveling....


A valid point was made, whether you agree with it or not, whether you like it or not.
If you're gonna write a book, then have enough courtesy for those having to read it in order to offer you their help and advice for free to use reasonable spacing and punctuation.

That is all !

texastea
09-18-2012, 01:39 PM
Yeah thanks for the reply,I do not know anything about how to install them.That is why I had them "professionally installed".They did not even angle the tweets .I think I got the shaft as they say I will have someone else look at it.Have any recomendations? I live in nowhere arkansas so I havent found much OBVIOUSLY, since I moved here from Mpls

hispls
09-18-2012, 01:52 PM
Sounds to me like a bad install. Have you gone back and asked why you paid a lot of money just for it to sound bad? Have you told them that you can't wait to show all of your friends, family, and associates just how awful a thousand dollars spent at their shop sounds? There are many different things that could cause the new equipment to sound bad.. But it is all install related and would be their fault anyway. It should sound good if it were installed correctly, even with a stock headunit.


Agreed 100%

That's not terrible gear, so it's absolutely a f*ck up on the part of the persons who installed and set up things.

texastea
09-18-2012, 02:10 PM
Here here old boy,point taken.Yes it was valid and, pointless.Ridiculous,as I stated before whether you like it or agree as you said.I was not writing a book.You were not reading a book.Certainly not one you bought.So you were reading it for "free".Seems sad to me that we live in a time when some (way too many)take themselves and life way to seriously.Giving someone help and advice should always be "FOR FREE"Helping people is an honor.When you do it out of kindness,you help yourself as much as you help them.No pre or set conditions,just kindness.If you have managed somehow to make some sense of this (without proper spacing and structure) I commend you.The problem you see is not one on myself trying to be rude,or discourteous,it is ignorance on my part.THAT IS ALL.I do not even know how to move the cursor to start a new paragraph.So if you are not willing to help because I did not space properly then don't,and THAT IS THAT

AlterEgo99
10-03-2012, 01:59 PM
Hi everyone I am a newbie in every sense of the word, when it comes to this car audio.If you don't mind I could use some info from someone, who can at least tell ya what a crossover is!Here is what I need help with please bear with me.I recently purchased an 02 avalanche 1500 w/onstar and a factory stereo.The speakers were all blown so I decided to replace.So I bought two sets of infinity kappa60.9cs 1 set for back and 1 for up front.Purchased an infinity 475a 4 channel amp to drive it.I had this professionally installed ( for 457.00) I might add but they rewired the doors also so The thing is it sounds absolutey horrible.I am told to up grade head unit.Is the head unit from factory that bad.Heck the old speakers that came from factory sounded better.Is it becauce I now have so much more power that you hear so much distortion or something the tweeters which he mounted up high by your ears in the back I think make more noise than music.Can the head unit be to blame I swear it sounded better 1000.00 $ back with cheap speakers.If it is What would you recommend.I have been narrowing it down with SOUND QUALITY and of course MONEY as main factor so we talk single din which lead me to pioneer or kenwood .Any help or advice would be deeply appreciated.I hope everyone is having a great year.Where I live in southern us it has been a hot DRY year and we finally ,(repeat) finally got some decent rain.At least it will help for next year! see ya and thanks

tl;dnr

http://i854.photobucket.com/albums/ab110/6crnbnh/1234567890/HPD-Hell.jpg

Welcome to Hell.