PDA

View Full Version : kenwood dnx9990 and relay ?



psylo535
09-01-2012, 12:01 PM
My 2 month old kenwood 9990 crapped out on me .The startrup screen just keeps rebooting over and over.The shop I bought it from sent it back to kenwood for warranty. Now the shop says the reason this happens is because this unit draws too much power or something like that. They told me to wire a relay between the battery and the headunit and I should be good to go. Has anyone heard of this or is it just a load of crap.I'm pretty pissed off that my new $1000+ headunit already had to go in for service and I had a hole in my dash for over a week. I have read on the kenwood forums that other people have had the same problem but never heard of using a relay to fix it

psylo535
09-03-2012, 08:13 AM
wow, a lot of help here.

maylar
09-03-2012, 10:14 AM
Sounds like BS to me.

psylo535
10-24-2012, 10:40 AM
Update. I had kenwood warranty fix the rebooting problem and all was well for about 5-6 weeks. Now I have a new problem that of course kenwoods answer is send it in. I am tired of taking it in and out and being without a stereo. It seems to randomly stop playing music through my front comps and my subwoofers. It goes off for a few seconds and then comes back on. This is at any listening level not just wide open.When the fronts and subs cut out my rear fill wired to the deck itself stays on. I really doubt it is 2 bad amps and 2 bad sets of rca's. I think there is an issue with the preouts on the deck. Any thoughts on this. I have had it with kenwood and their overpriced junk