PDA

View Full Version : Massive Audio CK6 Version V Review



ace_800
07-12-2012, 02:02 PM
Review of Subwoofer or Speaker:

I originally bought 2 sets of Massive Audio's CK6 V's back in October. I've had them install for the last 6-7 months and wanted to post a review after this long.

I installed the mids in the front doors and the tweeters in my A pillars, the rear set was coax'd in the rear doors. For about 4 months they were ran off a Massive Audio NX5, pushing 120 x 4. Needless to say I wasn't very happy with them. At high volumes they sounded extremely muffled. Even after adjusting my crossover settings on the amp they just didn't sound right.

I had planned on selling both sets and starting over with some HATS or another set, but decided to give them a little more time since I was switching out the NX5 and sub stage.

I got ahold of an Eclipse XA4000 pushing 125 x 4. Kept the xover at ~100 iirc, hi pass setting, freq ~55, no bass boost, Input level just below half. Sounded better and less muffled at higher volumes, but still not very happy.

I decided to start to change them out and sold the rear set, while I contemplated what set to buy to switch out the front set I bridged the Eclipse to push 250 x 2 to the front set. That made a dramatic change in the quality of sound. I still have the settings the same, except the input level which is now at just over 1/4. THEY SING. No muffled sound, loud and really clear. I have no thought of changing them out now, but am not going with any rear fill in my SUV. Doesn't need it.

So overall, they need a clean powered amp to push them correctly. The NX5 just wasn't doing it. I won't be selling them anytime soon.