PDA

View Full Version : SOLD/CLOSED 04 RE XXX 12" D2 **Pics**



Zeuslicious
02-28-2012, 02:04 PM
1. Product:
04 RE XXX 12"

2. Specs:
OEM Specs PSI Recone, 1500 rms, XBL^2, d2 ohms

3. Description/Condition:
Used but good condition overall as you can see in the pics. I love it but I don't need it anymore :)

4. Price:
I would like to get $300 in a local deal. Not in a rush to sell it and if it doesn't sell in a couple of days, I might ship her. Please pme if interested. (please don't ask me whats the lowest price I would do because I don't play that game, If you have an offer just pme)
Trades? only if you have a 4hp motor or a 3k+ amp.

5. Pictures:

http://i198.photobucket.com/albums/aa166/zeusliciouz/840e5f38.jpg
http://i198.photobucket.com/albums/aa166/zeusliciouz/143764ba.jpg
http://i198.photobucket.com/albums/aa166/zeusliciouz/a0366666.jpg
http://i198.photobucket.com/albums/aa166/zeusliciouz/ee277ca5.jpg

(List pictures in this section, 1st picture should be your username/date if you have less than 10 positive feedbacks with the i-Trader system or less than 10 references that you have sold to in the past. (These must be listed in your signature, or a link provided to a feedback thread listing these references)).

tc300
02-28-2012, 04:53 PM
Does it sound as it did b4 the recone...??

bhsdriller
02-28-2012, 05:29 PM
what softparts?

Edit: nevermind it says oem psi, should be the same as stock then

06goat
02-28-2012, 08:28 PM
Interesting backplate compared to the 05's. Havent seen one until now.

J31Rob
02-28-2012, 10:31 PM
Don't see too many 04s around. GLWS.

Zeuslicious
02-29-2012, 03:47 AM
^^^ Thanks Man...


Does it sound as it did b4 the recone...??
^^^ Seriously? lol Same Parts than 8 years ago bro...




2. Specs:
OEM Specs PSI Recone, 1500 rms, XBL^2, d2 ohms

tc300
02-29-2012, 03:56 AM
^^^ Thanks Man...


^^^ Seriously? lol Same Parts than 8 years ago bro...



Welll the reason why i ask this is cause my buddy blew his Q15 (clipped signal) and Fi had a 2month wait on recones so I suggested him to go to PSI to get it reconed... Put it back in the same box, set the gains correctly and it doesnt sound ANY thing close to what it did b4. Checked coils for the right impedance... Only thing can think of they didnt use the right coil...?

Zeuslicious
02-29-2012, 01:57 PM
Sorry to heard that bro but I have no idea about your Buddy sub or any FI Product or what coil/spiders or whatever FI or Dave use to build their recones, I stoped using FI products a few years ago because the lack of comunication from them.
Just I said before This is a OEM Recone that It was Build with the SAME OEM parts that they used a few years ago and that Probably it was Dave himself who built it back in the days when he used to worked at RE back in Vegas, If I remember correctly they were hand built for only 2-3 guys at RE Location.
Being said that I would really appreciate you stop posting/asking stuff that everybody knows already.
Please feel free to contact me or contact Dave at PSI/FMS if you have any other question about this Sub or your Buddy's sub/recone...
Thanks

Flipx99
02-29-2012, 03:19 PM
Wish it had the OE dustcap.

Zeuslicious
03-01-2012, 02:10 PM
I'm pretty sure Dave might have one laying around... Still for sale...

Loudmp5
03-01-2012, 02:26 PM
motor for what??

Zeuslicious
03-12-2012, 04:55 AM
Sold!!!